p PatchFirst

CVE-2025-48947

CVE-2025-48947 · NextJS-Auth0 SDK Vulnerable to CDN Caching of Session Cookies

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. In Auth0 Next.js SDK versions 4.0.1 through 4.6.0, `__session` cookies set by auth0.middleware may be cached by CDNs due to missing Cache-Control headers. Three preconditions must be met in order for someone to be affected by the vulnerability: Applications using the NextJS-Auth0 SDK, versions between 4.0.1 to 4.6.0, applications using CDN or edge caching that caches responses with the Set-Cookie header, and if the Cache-Control header is not properly set for sensitive responses. Users should upgrade auth0/nextjs-auth0 to v4.6.1 to receive a patch.

CVSS 7.7 · Высокий · EPSS 0,4% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • nextjs-auth0

    Версии
    • >= 4.0.1, < 4.6.1: Затронуто

    Нет опубликованного исправления

  • @auth0/nextjs-auth0 npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 4.0.1, < 4.6.1

    Обновитесь до 4.6.1

Первоисточники

Проверьте свой сервер →