p PatchFirst

CVE-2025-49763

CVE-2025-49763 · Apache Traffic Server: Remote DoS via memory exhaustion in ESI Plugin

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

ESI plugin does not have the limit for maximum inclusion depth, and that allows excessive memory consumption if malicious instructions are inserted. Users can use a new setting for the plugin (--max-inclusion-depth) to limit it. This issue affects Apache Traffic Server: from 10.0.0 through 10.0.5, from 9.0.0 through 9.2.10. Users are recommended to upgrade to version 9.2.11 or 10.0.6, which fixes the issue.

CVSS 7.5 · Высокий · EPSS 0,7% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • apache traffic server

    Версии
    • ≥ 10.0.0, ≤ 10.0.5: Затронуто (semver)
    • ≥ 9.0.0, ≤ 9.2.10: Затронуто (semver)

    Нет опубликованного исправления

  • trafficserver Debian:12

    Версии
    • 9.2.0+ds-2
    • 9.2.0+ds-2+deb12u1
    • 9.2.1+ds-1
    • 9.2.2+ds-1
    • 9.2.3+ds-1
    • 9.2.3+ds-1+deb12u1
    • 9.2.4+ds-0+deb12u1
    • 9.2.4+ds-1
    • 9.2.4+ds-2
    • 9.2.5+ds-0+deb12u1
    • 9.2.5+ds-0+deb12u2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 9.2.5+ds-0+deb12u3

    Обновитесь до 9.2.5+ds-0+deb12u3

  • trafficserver Ubuntu:16.04:LTS

    Версии
    • 5.3.0-2ubuntu1
    • 5.3.0-2ubuntu2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • trafficserver Ubuntu:18.04:LTS

    Версии
    • 7.0.0-5
    • 7.1.2+ds-2
    • 7.1.2+ds-2build1
    • 7.1.2+ds-3
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • trafficserver Ubuntu:Pro:20.04:LTS

    Версии
    • 8.0.5+ds-1
    • 8.0.5+ds-2
    • 8.0.5+ds-2build1
    • 8.0.5+ds-2ubuntu1
    • 8.0.5+ds-3
    • 8.0.5+ds-3ubuntu0.1~esm1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • trafficserver Ubuntu:Pro:22.04:LTS

    Версии
    • 8.1.1+ds-1.1
    • 9.1.1+ds-2build1
    • 9.1.1+ds-2ubuntu0.1~esm1
    • 9.1.1+ds-2ubuntu0.1
    • 9.1.1+ds-2ubuntu0.1+esm1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • trafficserver Ubuntu:24.04:LTS

    Версии
    • 9.2.1+ds-1build1
    • 9.2.2+ds-1
    • 9.2.3+ds-1
    • 9.2.3+ds-1+deb12u1
    • 9.2.3+ds-1+deb12u1build1
    • 9.2.3+ds-1+deb12u1build3
    • 9.2.3+ds-1+deb12u1build4
    • 9.2.3+ds-1+deb12u1ubuntu0.1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • trafficserver Ubuntu:25.10

    Версии
    • 9.2.5+ds-1ubuntu1
    • 9.2.5+ds-1ubuntu2
    • 9.2.5+ds-1ubuntu2.1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →