CVE-2025-50213
CVE-2025-50213 · Apache Airflow Providers Snowflake: Potential SQL injection in CopyFromExternalStageToSnowflakeOperator
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Failure to Sanitize Special Elements into a Different Plane (Special Element Injection) vulnerability in Apache Airflow Providers Snowflake. This issue affects Apache Airflow Providers Snowflake: before 6.4.0. Sanitation of table and stage parameters were added in CopyFromExternalStageToSnowflakeOperator to prevent SQL injection Users are recommended to upgrade to version 6.4.0, which fixes the issue.
CVSS 9.8 · Критический · EPSS 0,8% · Есть исправление
- Опубликовано
- Обновлено
Стек: python
Затронутые продукты и версии
apache airflow providers snowflake
- Версии
- ≥ 0, < 6.4.0: Затронуто (semver)
Обновитесь до 6.4.0
apache-airflow-providers-snowflake PyPI
- Версии
- 1.0.0
- 1.0.0b1
- 1.0.0b2
- 1.0.0rc1
- 1.1.0
- 1.1.0rc1
- 1.1.1
- 1.1.1rc1
- 1.1.1rc2
- 1.2.0
- 1.2.0rc1
- 1.3.0
- 1.3.0rc1
- 2.0.0
- 2.0.0rc1
- 2.0.0rc2
- 2.0.0rc3
- 2.1.0
- 2.1.0rc1
- 2.1.0rc2
- 2.1.1
- 2.1.1rc1
- 2.2.0
- 2.2.0rc1
- 2.3.0
- 2.3.0rc1
- 2.3.1
- 2.3.1rc1
- 2.4.0
- 2.4.0rc1
- 2.5.0
- 2.5.0rc1
- 2.5.0rc2
- 2.5.1
- 2.5.1rc1
- 2.5.2
- 2.5.2rc1
- 2.6.0
- 2.6.0rc1
- 2.7.0
- 2.7.0rc1
- 3.0.0
- 3.0.0rc1
- 3.0.0rc2
- 3.1.0
- 3.1.0rc1
- 3.2.0
- 3.2.0rc1
- 3.2.0rc2
- 3.2.0rc3
- 3.3.0
- 3.3.0rc1
- 4.0.0
- 4.0.0rc1
- 4.0.1
- 4.0.1rc2
- 4.0.1rc3
- 4.0.2
- 4.0.2rc1
- 4.0.3
- 4.0.3rc1
- 4.0.4
- 4.0.4rc1
- 4.0.5
- 4.0.5rc1
- 4.1.0
- 4.1.0rc1
- 4.1.0rc2
- 4.2.0
- 4.2.0rc1
- 4.3.0
- 4.3.0rc2
- 4.3.1
- 4.3.1rc1
- 4.4.0
- 4.4.0rc1
- 4.4.1
- 4.4.1rc1
- 4.4.2
- 4.4.2rc1
- 5.0.0
- 5.0.0rc1
- 5.0.1
- 5.0.1rc1
- 5.1.0
- 5.1.0rc1
- 5.1.1
- 5.1.1rc1
- 5.1.2
- 5.1.2rc1
- 5.2.0
- 5.2.0rc1
- 5.2.1
- 5.2.1rc1
- 5.3.0
- 5.3.0rc1
- 5.3.0rc2
- 5.3.1
- 5.3.1rc1
- 5.4.0
- 5.4.0rc1
- 5.5.0
- 5.5.0rc1
- 5.5.1
- 5.5.1rc1
- 5.5.2
- 5.5.2rc1
- 5.6.0
- 5.6.0rc1
- 5.6.1
- 5.6.1rc1
- 5.7.0
- 5.7.0rc1
- 5.7.1
- 5.7.1rc1
- 5.8.0
- 5.8.0rc1
- 5.8.1
- 5.8.1rc1
- 6.0.0
- 6.0.0rc1
- 6.0.0rc2
- 6.1.0
- 6.1.0rc1
- 6.1.1
- 6.1.1rc1
- 6.2.0
- 6.2.0rc1
- 6.2.1
- 6.2.1rc1
- 6.2.2
- 6.2.2rc1
- 6.3.0
- 6.3.0rc1
- 6.3.0rc2
- 6.3.1
- 6.3.1rc1
- 6.4.0rc1
- Затронутые диапазоны версий
- ECOSYSTEM: < 6.4.0
Обновитесь до 6.4.0