p PatchFirst

CVE-2025-5174

CVE-2025-5174 · erdogant pypickle pypickle.py load deserialization

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

A vulnerability was found in erdogant pypickle up to 1.1.5 and classified as problematic. Affected by this issue is the function load of the file pypickle/pypickle.py. The manipulation leads to deserialization. Local access is required to approach this attack. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.0 is able to address this issue. The patch is identified as 14b4cae704a0bb4eb6723e238f25382d847a1917. It is recommended to upgrade the affected component.

CVSS 4.8 · Средний · EPSS 0,3% · Есть исправление

Опубликовано
Обновлено

Стек: python

Затронутые продукты и версии

  • pypickle

    Версии
    • 1.1.0: Затронуто
    • 1.1.1: Затронуто
    • 1.1.2: Затронуто
    • 1.1.3: Затронуто
    • 1.1.4: Затронуто
    • 1.1.5: Затронуто

    Нет опубликованного исправления

  • pypickle PyPI

    Версии
    • 0.1.0
    • 0.1.1
    • 1.0.0
    • 1.1.0
    • 1.1.1
    • 1.1.3
    • 1.1.4
    • 1.1.5
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.0.0

    Обновитесь до 2.0.0

  • pypickle PyPI

    Версии
    • 0.1.0
    • 0.1.1
    • 1.0.0
    • 1.1.0
    • 1.1.1
    • 1.1.3
    • 1.1.4
    • 1.1.5
    • 1.1.2
    Затронутые диапазоны версий
    • {"events": [{"introduced": "0"}, {"fixed": "14b4cae704a0bb4eb6723e238f25382d847a1917"}, {"fixed": "5058ea8c0666b3f8d30893be5c0132ad7fb7bf39"}], "repo": "https://github.com/erdogant/pypickle", "type": "GIT"}
    • ECOSYSTEM: < 2.0.0

    Обновитесь до 2.0.0

Первоисточники

Проверьте свой сервер →