CVE-2025-53548
CVE-2025-53548 · @clerk/backend Performs Insufficient Verification of Data Authenticity
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Clerk helps developers build user management. Applications that use the verifyWebhook() helper to verify incoming Clerk webhooks are susceptible to accepting improperly signed webhook events. The issue was resolved in @clerk/backend 2.4.0.
CVSS 7.5 · Высокий · EPSS 0,2% · Есть исправление
- Опубликовано
- Обновлено
Стек: node
Затронутые продукты и версии
javascript
- Версии
- < 2.4.0: Затронуто
Нет опубликованного исправления
@clerk/backend npm
- Затронутые диапазоны версий
- SEMVER: ≥ 2.0.0, < 2.4.0
Обновитесь до 2.4.0
@clerk/astro npm
- Затронутые диапазоны версий
- SEMVER: ≥ 2.9.0, < 2.10.2
Обновитесь до 2.10.2
@clerk/express npm
- Затронутые диапазоны версий
- SEMVER: ≥ 1.6.0, < 1.7.4
Обновитесь до 1.7.4
@clerk/fastify npm
- Затронутые диапазоны версий
- SEMVER: ≥ 2.3.0, < 2.4.4
Обновитесь до 2.4.4
@clerk/nextjs npm
- Затронутые диапазоны версий
- SEMVER: ≥ 6.2.10, < 6.23.3
Обновитесь до 6.23.3
@clerk/nuxt npm
- Затронутые диапазоны версий
- SEMVER: ≥ 1.7.0, < 1.7.5
Обновитесь до 1.7.5
@clerk/react-router npm
- Затронутые диапазоны версий
- SEMVER: ≥ 1.5.0, < 1.6.4
Обновитесь до 1.6.4
@clerk/remix npm
- Затронутые диапазоны версий
- SEMVER: ≥ 4.8.0, < 4.8.5
Обновитесь до 4.8.5
@clerk/tanstack-react-start npm
- Затронутые диапазоны версий
- SEMVER: ≥ 0.16.0, < 0.18.3
Обновитесь до 0.18.3