p PatchFirst

CVE-2025-54073

CVE-2025-54073 · mcp-package-docs vulnerable to command injection in several tools

CVSS 7.5 · Высокий · EPSS 11,3% · Есть исправление

Затронуты ли вы?

Как узнать установленную версию:

npm ls mcp-package-docs

Бесплатная проверка покажет рейтинг сервера и подсветит, требует ли внимания mcp-package-docs и остальные программы. Без регистрации; имена серверов и IP-адреса не отправляются. Номера CVE, версии исправлений и рекомендации — в платном мониторинге.

curl -fsSL https://ru.patchfirst.dev/check.sh | sh
Проверить сервер бесплатно →

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

mcp-package-docs is an MCP (Model Context Protocol) server that provides LLMs with efficient access to package documentation across multiple programming languages and language server protocol (LSP) capabilities. A command injection vulnerability exists in the `mcp-package-docs` MCP Server prior to the fix in commit cb4ad49615275379fd6f2f1cf1ec4731eec56eb9. The vulnerability is caused by the unsanitized use of input parameters within a call to `child_process.exec`, enabling an attacker to inject arbitrary system commands. Successful exploitation can lead to remote code execution under the server process's privileges. The server constructs and executes shell commands using unvalidated user input directly within command-line strings. This introduces the possibility of shell metacharacter injection (`|`, `>`, `&&`, etc.). Commit cb4ad49615275379fd6f2f1cf1ec4731eec56eb9 in version 0.1.27 contains a fix for the issue, but upgrading to 0.1.28 is recommended.

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • mcp-package-docs

    Версии
    • < 0.1.27: Затронуто

    Нет опубликованного исправления

  • mcp-package-docs npm

    Затронутые диапазоны версий
    • SEMVER: < 0.1.28

    Обновитесь до 0.1.28

Первоисточники

Проверьте свой сервер →