CVE-2025-54080
CVE-2025-54080 · Exiv2 Segmentation Faults in Exiv2::EpsImage::writeMetadata() via crafted EPS file
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Exiv2 is a C++ library and a command-line utility to read, write, delete and modify Exif, IPTC, XMP and ICC image metadata. An out-of-bounds read was found in Exiv2 versions 0.28.5 and earlier. The out-of-bounds read is triggered when Exiv2 is used to write metadata into a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service by crashing Exiv2, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when writing the metadata, which is a less frequently used Exiv2 operation than reading the metadata. The bug is fixed in version 0.28.6.
CVSS 1.8 · Низкий · EPSS 0,1% · Есть исправление
- Опубликовано
- Обновлено
Затронутые продукты и версии
exiv2
- Версии
- < 0.28.6: Затронуто
Нет опубликованного исправления
exiv2 Debian:12
- Версии
- 0.27.6-1
- 0.28.0+dfsg-1
- 0.28.0+dfsg-2
- 0.28.0+dfsg-3
- 0.28.0+dfsg-4
- 0.28.1+dfsg-1
- 0.28.1+dfsg-2
- 0.28.1+dfsg-3
- 0.28.2+dfsg-1
- 0.28.3+dfsg-1
- 0.28.3+dfsg-2
- 0.28.4+dfsg-1
- 0.28.4+dfsg-2
- 0.28.5+dfsg-1
- 0.28.7+dfsg-1
- 0.28.7+dfsg-2
- 0.28.8+dfsg-1
- 0.28.9+dfsg-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
exiv2 Debian:13
- Версии
- 0.28.5+dfsg-1
- 0.28.7+dfsg-1
- 0.28.7+dfsg-2
- 0.28.8+dfsg-1
- 0.28.9+dfsg-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
exiv2 Debian:14
- Версии
- 0.28.5+dfsg-1
- 0.28.7+dfsg-1
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.28.7+dfsg-2
Обновитесь до 0.28.7+dfsg-2
exiv2 PyPI
- Версии
- 0.1
- 0.11.0
- 0.11.1
- 0.11.2
- 0.11.3
- 0.12.0
- 0.12.1
- 0.13.0
- 0.13.1
- 0.13.2
- 0.14.0
- 0.14.1
- 0.15.0
- 0.16.0
- 0.16.1
- 0.16.2
- 0.16.2.post1
- 0.16.3
- 0.16.3.post1
- 0.17.0
- 0.17.1
- 0.17.2
- 0.17.3
- 0.2
- 0.3
- 0.3.1
- Затронутые диапазоны версий
- ECOSYSTEM: ≤ 0.17.3
Нет опубликованного исправления
exiv2 Ubuntu:Pro:16.04:LTS
- Версии
- 0.25-1ubuntu1
- 0.25-2.1
- 0.25-2.1ubuntu16.04.1
- 0.25-2.1ubuntu16.04.2
- 0.25-2.1ubuntu16.04.3
- 0.25-2.1ubuntu16.04.4
- 0.25-2.1ubuntu16.04.5
- 0.25-2.1ubuntu16.04.6
- 0.25-2.1ubuntu16.04.7+esm1
- 0.25-2.1ubuntu16.04.7+esm2
- 0.25-2.1ubuntu16.04.7+esm3
- 0.25-2.1ubuntu16.04.7+esm4
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.25-2.1ubuntu16.04.7+esm5
Обновитесь до 0.25-2.1ubuntu16.04.7+esm5
exiv2 Ubuntu:Pro:18.04:LTS
- Версии
- 0.25-3.1
- 0.25-3.1ubuntu0.18.04.1
- 0.25-3.1ubuntu0.18.04.2
- 0.25-3.1ubuntu0.18.04.3
- 0.25-3.1ubuntu0.18.04.4
- 0.25-3.1ubuntu0.18.04.5
- 0.25-3.1ubuntu0.18.04.7
- 0.25-3.1ubuntu0.18.04.9
- 0.25-3.1ubuntu0.18.04.10
- 0.25-3.1ubuntu0.18.04.11
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.25-3.1ubuntu0.18.04.11+esm1
Обновитесь до 0.25-3.1ubuntu0.18.04.11+esm1
exiv2 Ubuntu:Pro:20.04:LTS
- Версии
- 0.25-4ubuntu2
- 0.25-4ubuntu3
- 0.27.2-8ubuntu2
- 0.27.2-8ubuntu2.2
- 0.27.2-8ubuntu2.4
- 0.27.2-8ubuntu2.5
- 0.27.2-8ubuntu2.6
- 0.27.2-8ubuntu2.7
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.27.2-8ubuntu2.7+esm1
Обновитесь до 0.27.2-8ubuntu2.7+esm1
exiv2 Ubuntu:22.04:LTS
- Версии
- 0.27.3-3ubuntu4
- 0.27.3-3.1ubuntu1
- 0.27.5-1ubuntu1
- 0.27.5-3ubuntu1
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.27.5-3ubuntu1.1
Обновитесь до 0.27.5-3ubuntu1.1
exiv2 Ubuntu:24.04:LTS
- Версии
- 0.27.6-1
- 0.27.6-1build1
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.27.6-1ubuntu0.1
Обновитесь до 0.27.6-1ubuntu0.1
exiv2 Ubuntu:25.10
- Версии
- 0.28.5+dfsg-1
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.28.5+dfsg-1ubuntu0.1
Обновитесь до 0.28.5+dfsg-1ubuntu0.1