CVE-2025-54419
CVE-2025-54419 · Node-SAML Contains SAML Signature Verification Vulnerability
CVSS 10.0 · Критический · EPSS 0,4% · Есть исправление
Затронуты ли вы?
- node-samlНет опубликованного исправления
- @node-saml/node-saml npmОбновитесь до 5.1.0
- passport-saml npmНет опубликованного исправления
- @node-saml/passport-saml npmОбновитесь до 5.1.0
Как узнать установленную версию:
npm ls @node-saml/node-samlnpm ls passport-samlnpm ls @node-saml/passport-samlБесплатная проверка покажет рейтинг сервера и подсветит, требует ли внимания node-saml и остальные программы. Без регистрации; имена серверов и IP-адреса не отправляются. Номера CVE, версии исправлений и рекомендации — в платном мониторинге.
curl -fsSL https://ru.patchfirst.dev/check.sh | shЗдесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
A SAML library not dependent on any frameworks that runs in Node. In version 5.0.1, Node-SAML loads the assertion from the (unsigned) original response document. This is different than the parts that are verified when checking signature. This allows an attacker to modify authentication details within a valid SAML assertion. For example, in one attack it is possible to remove any character from the SAML assertion username. To conduct the attack an attacker would need a validly signed document from the identity provider (IdP). This is fixed in version 5.1.0.
- Опубликовано
- Обновлено
Стек: node
Затронутые продукты и версии
node-saml
- Версии
- = 5.0.1: Затронуто
Нет опубликованного исправления
@node-saml/node-saml npm
- Затронутые диапазоны версий
- SEMVER: < 5.1.0
Обновитесь до 5.1.0
passport-saml npm
- Затронутые диапазоны версий
- SEMVER: ≤ 3.2.4
Нет опубликованного исправления
@node-saml/passport-saml npm
- Затронутые диапазоны версий
- SEMVER: < 5.1.0
Обновитесь до 5.1.0