p PatchFirst

CVE-2025-54584

CVE-2025-54584 · GitProxy is vulnerable to a packfile parsing exploit

CVSS 7.0 · Высокий · EPSS 0,6% · Есть исправление

Затронуты ли вы?

Как узнать установленную версию:

npm ls @finos/git-proxy

Бесплатная проверка покажет рейтинг сервера и подсветит, требует ли внимания git-proxy и остальные программы. Без регистрации; имена серверов и IP-адреса не отправляются. Номера CVE, версии исправлений и рекомендации — в платном мониторинге.

curl -fsSL https://ru.patchfirst.dev/check.sh | sh
Проверить сервер бесплатно →

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

GitProxy is an application that stands between developers and a Git remote endpoint (e.g., github.com). In versions 1.19.1 and below, an attacker can craft a malicious Git packfile to exploit the PACK signature detection in the parsePush.ts file. By embedding a misleading PACK signature within commit content and carefully constructing the packet structure, the attacker can trick the parser into treating invalid or unintended data as the packfile. Potentially, this would allow bypassing approval or hiding commits. This issue is fixed in version 1.19.2.

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • git-proxy

    Версии
    • < 1.19.2: Затронуто

    Нет опубликованного исправления

  • @finos/git-proxy npm

    Затронутые диапазоны версий
    • SEMVER: < 1.19.2

    Обновитесь до 1.19.2

Первоисточники

Проверьте свой сервер →