p PatchFirst

CVE-2025-54585

CVE-2025-54585 · GitProxy is vulnerable to a new branch approval exploit

CVSS 8.2 · Высокий · EPSS 0,4% · Есть исправление

Затронуты ли вы?

Как узнать установленную версию:

npm ls @finos/git-proxy

Бесплатная проверка покажет рейтинг сервера и подсветит, требует ли внимания git-proxy и остальные программы. Без регистрации; имена серверов и IP-адреса не отправляются. Номера CVE, версии исправлений и рекомендации — в платном мониторинге.

curl -fsSL https://ru.patchfirst.dev/check.sh | sh
Проверить сервер бесплатно →

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

GitProxy is an application that stands between developers and a Git remote endpoint. In versions 1.19.1 and below, attackers can exploit the way GitProxy handles new branch creation to bypass the approval of prior commits on the parent branch. The vulnerability impacts all users or organizations relying on GitProxy to enforce policy and prevent unapproved changes. It requires no elevated privileges beyond regular push access, and no extra user interaction. It does however, require a GitProxy administrator or designated user (canUserApproveRejectPush) to approve pushes to the child branch. This is fixed in version 1.19.2.

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • git-proxy

    Версии
    • < 1.19.2: Затронуто

    Нет опубликованного исправления

  • @finos/git-proxy npm

    Затронутые диапазоны версий
    • SEMVER: < 1.19.2

    Обновитесь до 1.19.2

Первоисточники

Проверьте свой сервер →