CVE-2025-55163
CVE-2025-55163 · Netty MadeYouReset HTTP/2 DDoS Vulnerability
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.124.Final and 4.2.4.Final, Netty is vulnerable to MadeYouReset DDoS. This is a logical vulnerability in the HTTP/2 protocol, that uses malformed HTTP/2 control frames in order to break the max concurrent streams limit - which results in resource exhaustion and distributed denial of service. This issue has been patched in versions 4.1.124.Final and 4.2.4.Final.
CVSS 8.2 · Высокий · EPSS 1,1% · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
netty
- Версии
- < 4.1.124.Final: Затронуто
- < 4.2.4.Final: Затронуто
Нет опубликованного исправления
netty Debian:12
- Версии
- 1:4.1.48-7
- 1:4.1.48-7+deb12u1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1:4.1.48-7+deb12u2
Обновитесь до 1:4.1.48-7+deb12u2
netty Debian:13
- Версии
- 1:4.1.48-10
- Затронутые диапазоны версий
- ECOSYSTEM: < 1:4.1.48-10+deb13u1
Обновитесь до 1:4.1.48-10+deb13u1
netty Debian:14
- Версии
- 1:4.1.48-10
- Затронутые диапазоны версий
- ECOSYSTEM: < 1:4.1.48-11
Обновитесь до 1:4.1.48-11
netty Ubuntu:Pro:14.04:LTS
- Версии
- 1:3.2.6.Final-2
- 1:3.2.6.Final-2+deb8u2build0.14.04.1~esm1
- 1:3.2.6.Final-2+deb8u2ubuntu0.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
netty Ubuntu:Pro:16.04:LTS
- Версии
- 1:3.2.6.Final-2
- 1:4.0.32-1
- 1:4.0.33-1
- 1:4.0.34-1
- 1:4.0.34-1ubuntu0.1~esm1
- 1:4.0.34-1ubuntu0.1~esm2
- 1:4.0.34-1ubuntu0.1~esm3
- 1:4.0.34-1ubuntu0.1~esm4
- Затронутые диапазоны версий
- ECOSYSTEM: < 1:4.0.34-1ubuntu0.1~esm5
Обновитесь до 1:4.0.34-1ubuntu0.1~esm5
netty Ubuntu:Pro:18.04:LTS
- Версии
- 1:4.1.7-4
- 1:4.1.7-4ubuntu0.1~esm1
- 1:4.1.7-4ubuntu0.1
- 1:4.1.7-4ubuntu0.1+esm1
- 1:4.1.7-4ubuntu0.1+esm2
- 1:4.1.7-4ubuntu0.1+esm3
- 1:4.1.7-4ubuntu0.1+esm4
- 1:4.1.7-4ubuntu0.1+esm5
- 1:4.1.7-4ubuntu0.1+esm6
- Затронутые диапазоны версий
- ECOSYSTEM: < 1:4.1.7-4ubuntu0.1+esm7
Обновитесь до 1:4.1.7-4ubuntu0.1+esm7
netty Ubuntu:Pro:20.04:LTS
- Версии
- 1:4.1.33-1
- 1:4.1.33-2
- 1:4.1.33-3
- 1:4.1.45-1
- 1:4.1.45-1ubuntu0.1~esm1
- 1:4.1.45-1ubuntu0.1~esm2
- 1:4.1.45-1ubuntu0.1~esm3
- 1:4.1.45-1ubuntu0.1~esm4
- 1:4.1.45-1ubuntu0.1~esm6
- Затронутые диапазоны версий
- ECOSYSTEM: < 1:4.1.45-1ubuntu0.1~esm7
Обновитесь до 1:4.1.45-1ubuntu0.1~esm7
netty Ubuntu:22.04:LTS
- Версии
- 1:4.1.48-4
- 1:4.1.48-4+deb11u1build0.22.04.1
- 1:4.1.48-4+deb11u2build0.22.04.1
- 1:4.1.48-4+deb11u2ubuntu0.1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1:4.1.48-4+deb11u2ubuntu0.2
Обновитесь до 1:4.1.48-4+deb11u2ubuntu0.2
netty Ubuntu:Pro:22.04:LTS
- Версии
- 1:4.1.48-4
- 1:4.1.48-4+deb11u1build0.22.04.1
- 1:4.1.48-4+deb11u2build0.22.04.1
- 1:4.1.48-4+deb11u2ubuntu0.1~esm1
- 1:4.1.48-4+deb11u2ubuntu0.1~esm2
- 1:4.1.48-4+deb11u2ubuntu0.1
- 1:4.1.48-4+deb11u2ubuntu0.1+esm1
- 1:4.1.48-4+deb11u2ubuntu0.1+esm3
- 1:4.1.48-4+deb11u2ubuntu0.2
- Затронутые диапазоны версий
- ECOSYSTEM: < 1:4.1.48-4+deb11u2ubuntu0.2+esm1
Обновитесь до 1:4.1.48-4+deb11u2ubuntu0.2+esm1
netty Ubuntu:24.04:LTS
- Версии
- 1:4.1.48-7
- 1:4.1.48-8
- 1:4.1.48-9
- 1:4.1.48-9ubuntu0.1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1:4.1.48-9ubuntu0.2
Обновитесь до 1:4.1.48-9ubuntu0.2
netty Ubuntu:Pro:24.04:LTS
- Версии
- 1:4.1.48-7
- 1:4.1.48-8
- 1:4.1.48-9
- 1:4.1.48-9ubuntu0.1~esm1
- 1:4.1.48-9ubuntu0.1~esm2
- 1:4.1.48-9ubuntu0.1
- 1:4.1.48-9ubuntu0.1+esm1
- 1:4.1.48-9ubuntu0.1+esm3
- 1:4.1.48-9ubuntu0.2
- Затронутые диапазоны версий
- ECOSYSTEM: < 1:4.1.48-9ubuntu0.2+esm1
Обновитесь до 1:4.1.48-9ubuntu0.2+esm1
netty Ubuntu:25.10
- Версии
- 1:4.1.48-10
- 1:4.1.48-10ubuntu0.25.10.1
- 1:4.1.48-10ubuntu0.25.10.2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
netty Ubuntu:26.10
- Версии
- 1:4.1.48-16
- 1:4.1.48-16ubuntu1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления