p PatchFirst

CVE-2025-55173

CVE-2025-55173 · Next.js Content Injection Vulnerability for Image Optimization

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Next.js is a React framework for building full-stack web applications. In versions before 14.2.31 and from 15.0.0 to before 15.4.5, Next.js Image Optimization is vulnerable to content injection. The issue allowed attacker-controlled external image sources to trigger file downloads with arbitrary content and filenames under specific configurations. This behavior could be abused for phishing or malicious file delivery. This vulnerability has been fixed in Next.js versions 14.2.31 and 15.4.5.

CVSS 4.3 · Средний · EPSS 0,6% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • next.js

    Версии
    • >= 15.0.0, < 15.4.5: Затронуто
    • < 14.2.31: Затронуто

    Нет опубликованного исправления

  • next npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 0.9.9, < 14.2.31

    Обновитесь до 14.2.31

  • next npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 15.0.0, < 15.4.5

    Обновитесь до 15.4.5

Первоисточники

Проверьте свой сервер →