p PatchFirst

CVE-2025-57822

CVE-2025-57822 · Next.js Improper Middleware Redirect Handling Leads to SSRF

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Next.js is a React framework for building full-stack web applications. Prior to versions 14.2.32 and 15.4.7, when next() was used without explicitly passing the request object, it could lead to SSRF in self-hosted applications that incorrectly forwarded user-supplied headers. This vulnerability has been fixed in Next.js versions 14.2.32 and 15.4.7. All users implementing custom middleware logic in self-hosted environments are strongly encouraged to upgrade and verify correct usage of the next() function.

CVSS 6.5 · Средний · EPSS 2,6% · Публичный эксплойт · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • next.js

    Версии
    • < 14.2.32: Затронуто
    • < 15.4.7: Затронуто

    Нет опубликованного исправления

  • next npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 0.9.9, < 14.2.32

    Обновитесь до 14.2.32

  • next npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 15.0.0-canary.0, < 15.4.7

    Обновитесь до 15.4.7

Первоисточники

Проверьте свой сервер →