CVE-2025-5889
CVE-2025-5889 · juliangruber brace-expansion index.js expand redos
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
A vulnerability was found in juliangruber brace-expansion up to 1.1.11/2.0.1/3.0.0/4.0.0. It has been rated as problematic. Affected by this issue is the function expand of the file index.js. The manipulation leads to inefficient regular expression complexity. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 1.1.12, 2.0.2, 3.0.1 and 4.0.1 is able to address this issue. The name of the patch is a5b98a4f30d7813266b221435e1eaaf25a1b0ac5. It is recommended to upgrade the affected component.
CVSS 2.3 · Низкий · EPSS 0,6% · Есть исправление
- Опубликовано
- Обновлено
Затронутые продукты и версии
brace-expansion
- Версии
- 1.1.0: Затронуто
- 1.1.1: Затронуто
- 1.1.2: Затронуто
- 1.1.3: Затронуто
- 1.1.4: Затронуто
- 1.1.5: Затронуто
- 1.1.6: Затронуто
- 1.1.7: Затронуто
- 1.1.8: Затронуто
- 1.1.9: Затронуто
- 1.1.10: Затронуто
- 1.1.11: Затронуто
- 2.0.0: Затронуто
- 2.0.1: Затронуто
- 3.0: Затронуто
- 4.0: Затронуто
- 1.1.12: Не затронуто
- 2.0.2: Не затронуто
- 3.0.1: Не затронуто
- 4.0.1: Не затронуто
Обновитесь до 1.1.12; Обновитесь до 2.0.2; Обновитесь до 3.0.1; Обновитесь до 4.0.1
node-brace-expansion Debian:12
- Версии
- 2.0.1+~1.1.0-1
- 2.0.1+~1.1.0-2
- 2.0.1-2
- 2.0.3+~1.1.2-1
- 2.0.3+~1.1.2-2
- 2.0.3+~1.1.2-3
- 2.1.4+~1.1.2-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-brace-expansion Debian:13
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.0.1+~1.1.0-2
Обновитесь до 2.0.1+~1.1.0-2
node-brace-expansion Debian:14
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.0.1+~1.1.0-2
Обновитесь до 2.0.1+~1.1.0-2
brace-expansion npm
- Затронутые диапазоны версий
- SEMVER: ≥ 2.0.0, < 2.0.2
Обновитесь до 2.0.2
brace-expansion npm
- Затронутые диапазоны версий
- SEMVER: ≥ 1.0.0, < 1.1.12
Обновитесь до 1.1.12
brace-expansion npm
- Версии
- 3.0.0
- Затронутые диапазоны версий
- SEMVER: ≥ 3.0.0, < 3.0.1
Обновитесь до 3.0.1
brace-expansion npm
- Версии
- 4.0.0
- Затронутые диапазоны версий
- SEMVER: ≥ 4.0.0, < 4.0.1
Обновитесь до 4.0.1
node-brace-expansion Ubuntu:18.04:LTS
- Версии
- 1.1.8-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-brace-expansion Ubuntu:20.04:LTS
- Версии
- 1.1.8-1
- 1.1.11-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-brace-expansion Ubuntu:22.04:LTS
- Версии
- 2.0.0-1
- 2.0.1-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-brace-expansion Ubuntu:24.04:LTS
- Версии
- 2.0.1-2
- 2.0.1+~1.1.0-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-brace-expansion Ubuntu:25.10
- Версии
- 2.0.1+~1.1.0-1
- 2.0.1+~1.1.0-2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
Первоисточники
- https://vuldb.com/?id.311660
- https://vuldb.com/?ctiid.311660
- https://vuldb.com/?submit.585717
- https://gist.github.com/mmmsssttt404/37a40ce7d6e5ca604858fe30814d9466
- https://github.com/juliangruber/brace-expansion/pull/65/commits/a5b98a4f30d7813266b221435e1eaaf25a1b0ac5
- https://github.com/juliangruber/brace-expansion/releases/tag/v4.0.1
- https://nvd.nist.gov/vuln/detail/CVE-2025-5889