p PatchFirst

CVE-2025-59034

CVE-2025-59034 · Indico may disclose unauthorized user details access via legacy API

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Indico is an event management system that uses Flask-Multipass, a multi-backend authentication system for Flask. Prior to version 3.3.8, a legacy API to retrieve user details could be misused to retrieve profile details of other users without having admin permissions due to a broken access check. Users should to update to Indico 3.3.8 as soon as possible. As a workaround, it is possible to restrict access to the affected API (e.g. in the webserver config).

CVSS 4.3 · Средний · EPSS 0,3% · Есть исправление

Опубликовано
Обновлено

Стек: python

Затронутые продукты и версии

  • indico

    Версии
    • < 3.3.8: Затронуто

    Нет опубликованного исправления

  • indico PyPI

    Версии
    • 0.98-rc1
    • 0.98.0
    • 0.98.1
    • 0.98.2
    • 0.99
    • 1.0
    • 1.1
    • 1.1.1
    • 1.1.2
    • 1.2
    • 1.2.1
    • 1.2.1rc10
    • 1.2.1rc11
    • 1.2.1rc2
    • 1.2.1rc4
    • 1.2.1rc5
    • 1.2.1rc6
    • 1.2.1rc7
    • 1.2.1rc9
    • 1.2.2
    • 1.2.2rc1
    • 1.9.11.dev10
    • 1.9.11.dev11
    • 1.9.11.dev12
    • 1.9.11.dev13
    • 1.9.11.dev14
    • 1.9.11.dev15
    • 1.9.11.dev16
    • 1.9.11.dev17
    • 1.9.11.dev3
    • 1.9.11.dev4
    • 1.9.11.dev6
    • 1.9.11.dev7
    • 1.9.11.dev8
    • 1.9.11.dev9
    • 2.0
    • 2.0.1
    • 2.0.2
    • 2.0.3
    • 2.0a1
    • 2.0rc1
    • 2.0rc2
    • 2.1
    • 2.1.1
    • 2.1.10
    • 2.1.11
    • 2.1.2
    • 2.1.3
    • 2.1.4
    • 2.1.5
    • 2.1.6
    • 2.1.7
    • 2.1.8
    • 2.1.9
    • 2.2
    • 2.2.1
    • 2.2.2
    • 2.2.3
    • 2.2.4
    • 2.2.5
    • 2.2.6
    • 2.2.7
    • 2.2.8
    • 2.3
    • 2.3.1
    • 2.3.2
    • 2.3.3
    • 2.3.4
    • 2.3.5
    • 3.0
    • 3.0.1
    • 3.0.2
    • 3.0.3
    • 3.0rc1
    • 3.0rc2
    • 3.1
    • 3.1.1
    • 3.2
    • 3.2.1
    • 3.2.2
    • 3.2.3
    • 3.2.4
    • 3.2.5
    • 3.2.6
    • 3.2.7
    • 3.2.8
    • 3.2.9
    • 3.3
    • 3.3.1
    • 3.3.2
    • 3.3.3
    • 3.3.4
    • 3.3.5
    • 3.3.6
    • 3.3.7
    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.3.8

    Обновитесь до 3.3.8

Первоисточники

Проверьте свой сервер →