CVE-2025-59057
CVE-2025-59057 · React Router has XSS Vulnerability
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
React Router is a router for React. In @remix-run/react versions 1.15.0 through 2.17.0. and react-router versions 7.0.0 through 7.8.2, a XSS vulnerability exists in in React Router's meta()/<Meta> APIs in Framework Mode when generating script:ld+json tags which could allow arbitrary JavaScript execution during SSR if untrusted content is used to generate the tag. There is no impact if the application is being used in Declarative Mode (<BrowserRouter>) or Data Mode (createBrowserRouter/<RouterProvider>). This issue has been patched in @remix-run/react version 2.17.1 and react-router version 7.9.0.
CVSS 7.6 · Высокий · EPSS 0,5% · Есть исправление
- Опубликовано
- Обновлено
Стек: node
Затронутые продукты и версии
react-router
- Версии
- @remix-run/react >= 1.15.0, < 2.17.1: Затронуто
- react-router >= 7.0.0, < 7.9.0: Затронуто
Нет опубликованного исправления
react-router npm
- Затронутые диапазоны версий
- SEMVER: ≥ 7.0.0, < 7.9.0
Обновитесь до 7.9.0
@remix-run/react npm
- Затронутые диапазоны версий
- SEMVER: ≥ 1.15.0, < 2.17.1
Обновитесь до 2.17.1
Первоисточники
- https://github.com/remix-run/react-router/security/advisories/GHSA-3cgp-3xvw-98x8
- https://access.redhat.com/security/cve/CVE-2025-59057
- https://bugzilla.redhat.com/show_bug.cgi?id=2428426
- https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-59057.json
- https://access.redhat.com/errata/RHSA-2026:3958
- https://access.redhat.com/errata/RHSA-2026:3960
- https://access.redhat.com/errata/RHSA-2026:3782
- https://access.redhat.com/errata/RHSA-2026:19712
- https://nvd.nist.gov/vuln/detail/CVE-2025-59057