CVE-2025-59155
CVE-2025-59155 · hackmd-mcp server-side request forgery in HTTP transport mode
CVSS 6.9 · Средний · EPSS 0,4% · Есть исправление
Затронуты ли вы?
- hackmd-mcpНет опубликованного исправления
- hackmd-mcp npmОбновитесь до 1.5.0
Как узнать установленную версию:
npm ls hackmd-mcpБесплатная проверка покажет рейтинг сервера и подсветит, требует ли внимания hackmd-mcp и остальные программы. Без регистрации; имена серверов и IP-адреса не отправляются. Номера CVE, версии исправлений и рекомендации — в платном мониторинге.
curl -fsSL https://ru.patchfirst.dev/check.sh | shЗдесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
hackmd-mcp is a Model Context Protocol server for integrating HackMD's note-taking platform with AI assistants. From 1.4.0 to before 1.5.0, hackmd-mcp contains a server-side request forgery (SSRF) vulnerability when the server is run in HTTP transport mode. Arbitrary hackmdApiUrl values supplied via the Hackmd-Api-Url HTTP header or a base64-encoded JSON query parameter are accepted without validation, allowing attackers to redirect outbound API requests to internal network services, access internal endpoints, perform network reconnaissance, and bypass network access controls. The stdio transport mode is not affected because it only accepts stdio requests. The issue is fixed in version 1.5.0, which enforces allowed endpoints and supports the ALLOWED_HACKMD_API_URLS environment variable. Users should update to 1.5.0 or later or apply documented mitigations such as switching to stdio mode, restricting outbound network access, or filtering the Hackmd-Api-Url header and related query parameter via a reverse proxy.
- Опубликовано
- Обновлено
Стек: node
Затронутые продукты и версии
hackmd-mcp
- Версии
- >= 1.4.0, < 1.5.0: Затронуто
Нет опубликованного исправления
hackmd-mcp npm
- Затронутые диапазоны версий
- SEMVER: ≥ 1.4.0, < 1.5.0
Обновитесь до 1.5.0