CVE-2025-59160
CVE-2025-59160 · matrix-js-sdk has insufficient validation when considering a room to be upgraded by another
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Matrix JavaScript SDK is a Matrix Client-Server SDK for JavaScript and TypeScript. matrix-js-sdk before 38.2.0 has insufficient validation of room predecessor links in MatrixClient::getJoinedRooms, allowing a remote attacker to attempt to replace a tombstoned room with an unrelated attacker-supplied room. The issue has been patched and users should upgrade to 38.2.0. A workaround is to avoid using MatrixClient::getJoinedRooms in favor of getRooms() and filtering upgraded rooms separately.
CVSS 2.7 · Низкий · EPSS 0,2% · Есть исправление
- Опубликовано
- Обновлено
Затронутые продукты и версии
matrix-js-sdk
- Версии
- < 38.2.0: Затронуто
Нет опубликованного исправления
node-matrix-js-sdk Debian:11
- Версии
- 9.11.0+~cs9.9.16-1
- 9.11.0+~cs9.9.16-2
- 9.3.0+~cs9.9.16-2
- 9.7.0~~rc1+~cs9.9.16-1
- 9.7.0~~rc1+~cs9.9.16-2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
matrix-js-sdk npm
- Затронутые диапазоны версий
- SEMVER: < 38.2.0
Обновитесь до 38.2.0
node-matrix-js-sdk Ubuntu:20.04:LTS
- Версии
- 0.9.2-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-matrix-js-sdk Ubuntu:22.04:LTS
- Версии
- 9.3.0+~cs9.9.16-2
- 9.11.0+~cs9.9.16-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-matrix-js-sdk Ubuntu:24.04:LTS
- Версии
- 9.11.0+~cs9.9.16-2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления