CVE-2025-59343
CVE-2025-59343 · tar-fs has a symlink validation bypass if destination directory is predictable with a specific tarball
CVSS 8.7 · Высокий · EPSS 0,6% · Есть исправление
Затронуты ли вы?
- tar-fsНет опубликованного исправления
- node-tar-fs Debian 12Обновитесь до 2.1.3-0+deb12u2
- node-tar-fs Debian 13Обновитесь до 3.0.9+~cs2.0.4-1+deb13u1
- node-tar-fs Debian 14Обновитесь до 3.0.9+~cs2.0.4-2
- и ещё 4
Как узнать установленную версию:
dpkg-query -W -f='${source:Package} ${binary:Package} ${Version}\n' | awk '$1=="node-tar-fs"'Бесплатная проверка покажет рейтинг сервера и подсветит, требует ли внимания tar-fs и остальные программы. Без регистрации; имена серверов и IP-адреса не отправляются. Номера CVE, версии исправлений и рекомендации — в платном мониторинге.
curl -fsSL https://ru.patchfirst.dev/check.sh | shЗдесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
tar-fs provides filesystem bindings for tar-stream. Versions prior to 3.1.1, 2.1.3, and 1.16.5 are vulnerable to symlink validation bypass if the destination directory is predictable with a specific tarball. This issue has been patched in version 3.1.1, 2.1.4, and 1.16.6. A workaround involves using the ignore option on non files/directories.
- Опубликовано
- Обновлено
Затронутые продукты и версии
tar-fs
- Версии
- >= 3.0.0, < 3.1.1: Затронуто
- >= 2.0.0, < 2.1.3: Затронуто
- < 1.16.5: Затронуто
Нет опубликованного исправления
node-tar-fs Debian 12
- Версии
- 2.1.1-6
- 2.1.3-0+deb12u1
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.1.3-0+deb12u2
Обновитесь до 2.1.3-0+deb12u2
node-tar-fs Debian 13
- Версии
- 3.0.9+~cs2.0.4-1
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.0.9+~cs2.0.4-1+deb13u1
Обновитесь до 3.0.9+~cs2.0.4-1+deb13u1
node-tar-fs Debian 14
- Версии
- 3.0.9+~cs2.0.4-1
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.0.9+~cs2.0.4-2
Обновитесь до 3.0.9+~cs2.0.4-2
tar-fs npm
- Затронутые диапазоны версий
- SEMVER: ≥ 3.0.0, < 3.1.1
Обновитесь до 3.1.1
tar-fs npm
- Затронутые диапазоны версий
- SEMVER: ≥ 2.0.0, < 2.1.4
Обновитесь до 2.1.4
tar-fs npm
- Затронутые диапазоны версий
- SEMVER: < 1.16.6
Обновитесь до 1.16.6
node-tar-fs Ubuntu Pro 22.04 LTS
- Версии
- 2.1.1-2
- 2.1.1-4
- 2.1.1-6
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.1.1-6ubuntu0.22.04.1~esm1
Обновитесь до 2.1.1-6ubuntu0.22.04.1~esm1
node-tar-fs Ubuntu Pro 24.04 LTS
- Версии
- 2.1.1-6
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.1.1-6ubuntu0.24.04.1~esm1
Обновитесь до 2.1.1-6ubuntu0.24.04.1~esm1
node-tar-fs Ubuntu 25.10
- Версии
- 2.1.1-6
- 3.0.8+~cs2.0.4-1
- 3.0.9+~cs2.0.4-1
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.0.9+~cs2.0.4-1+deb13u1build0.25.10.1
Обновитесь до 3.0.9+~cs2.0.4-1+deb13u1build0.25.10.1