CVE-2025-59471
CVE-2025-59471
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
A denial of service vulnerability exists in self-hosted Next.js applications that have `remotePatterns` configured for the Image Optimizer. The image optimization endpoint (`/_next/image`) loads external images entirely into memory without enforcing a maximum size limit, allowing an attacker to cause out-of-memory conditions by requesting optimization of arbitrarily large images. This vulnerability requires that `remotePatterns` is configured to allow image optimization from external domains and that the attacker can serve or control a large image on an allowed domain. Strongly consider upgrading to 15.5.10 or 16.1.5 to reduce risk and prevent availability issues in Next applications.
CVSS 5.9 · Средний · EPSS 0,5% · Есть исправление
- Опубликовано
- Обновлено
Стек: node
Затронутые продукты и версии
next
- Версии
- ≥ 10.0, < 10.0: Затронуто (semver)
- ≥ 11.0, < 11.0: Затронуто (semver)
- ≥ 12.0, < 12.0: Затронуто (semver)
- ≥ 13.0, < 13.0: Затронуто (semver)
- ≥ 14.0, < 14.0: Затронуто (semver)
- ≥ 15.0, < 15.5.10: Затронуто (semver)
- ≥ 16.0, < 16.1.5: Затронуто (semver)
Обновитесь до 15.5.10; Обновитесь до 16.1.5
next npm
- Затронутые диапазоны версий
- SEMVER: ≥ 10.0.0, < 15.5.10
Обновитесь до 15.5.10
next npm
- Затронутые диапазоны версий
- SEMVER: ≥ 15.6.0-canary.0, < 16.1.5
Обновитесь до 16.1.5