CVE-2025-59840
CVE-2025-59840 · Vega Cross-Site Scripting (XSS) via expressions abusing toString calls in environments using the VEGA_DEBUG global variable
CVSS 8.1 · Высокий · EPSS 0,4% · Есть исправление
Затронуты ли вы?
- vegaНет опубликованного исправления
- vega.js Debian 12Нет опубликованного исправления
- vega.js Debian 13Нет опубликованного исправления
- vega.js Debian 14Обновитесь до 5.33.1+ds+~cs5.3.0-4
- и ещё 7
Как узнать установленную версию:
dpkg-query -W -f='${source:Package} ${binary:Package} ${Version}\n' | awk '$1=="vega.js"'Бесплатная проверка покажет рейтинг сервера и подсветит, требует ли внимания vega и остальные программы. Без регистрации; имена серверов и IP-адреса не отправляются. Номера CVE, версии исправлений и рекомендации — в платном мониторинге.
curl -fsSL https://ru.patchfirst.dev/check.sh | shЗдесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. In Vega prior to version 6.2.0, applications meeting 2 conditions are at risk of arbitrary JavaScript code execution, even if "safe mode" expressionInterpreter is used. They are vulnerable if they use `vega` in an application that attaches `vega` library and a `vega.View` instance similar to the Vega Editor to the global `window` and if they allow user-defined Vega `JSON` definitions (vs JSON that was is only provided through source code). Patches are available in the following Vega applications. If using the latest Vega line (6.x), upgrade to `vega` `6.2.0` / `vega-expression` `6.1.0` / `vega-interpreter` `2.2.1` (if using AST evaluator mode). If using Vega in a non-ESM environment, upgrade to `vega-expression` `5.2.1` / `1.2.1` (if using AST evaluator mode). Some workarounds are available. Do not attach `vega` View instances to global variables, and do not attach `vega` to the global window. These practices of attaching the vega library and View instances may be convenient for debugging, but should not be used in production or in any situation where vega/vega-lite definitions could be provided by untrusted parties.
- Опубликовано
- Обновлено
Затронутые продукты и версии
vega
- Версии
- vega < 6.2.0: Затронуто
- vega-expression >= 6.0.0, < 6.1.0: Затронуто
- vega-expression < 5.2.1: Затронуто
- vega-interpreter >= 2.0.0, < 2.2.1: Затронуто
- vega-interpreter < 1.2.1: Затронуто
Нет опубликованного исправления
vega.js Debian 12
- Версии
- 5.22.1+ds+~3.1.0-4
- 5.25.0+ds+~cs5.3.0-1
- 5.25.0+ds+~cs5.3.0-2
- 5.25.0+ds+~cs5.3.0-3
- 5.25.0+ds+~cs5.3.0-4
- 5.25.0+ds+~cs5.3.0-5
Все версии (13)
- 5.28.0+ds+~cs5.3.0-1
- 5.28.0+ds+~cs5.3.0-2
- 5.28.0+ds+~cs5.3.0-3
- 5.33.1+ds+~cs5.3.0-1
- 5.33.1+ds+~cs5.3.0-2
- 5.33.1+ds+~cs5.3.0-3
- 5.33.1+ds+~cs5.3.0-4
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
vega.js Debian 13
- Версии
- 5.28.0+ds+~cs5.3.0-1
- 5.28.0+ds+~cs5.3.0-2
- 5.28.0+ds+~cs5.3.0-3
- 5.33.1+ds+~cs5.3.0-1
- 5.33.1+ds+~cs5.3.0-2
- 5.33.1+ds+~cs5.3.0-3
Все версии (7)
- 5.33.1+ds+~cs5.3.0-4
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
vega.js Debian 14
- Версии
- 5.28.0+ds+~cs5.3.0-1
- 5.28.0+ds+~cs5.3.0-2
- 5.28.0+ds+~cs5.3.0-3
- 5.33.1+ds+~cs5.3.0-1
- 5.33.1+ds+~cs5.3.0-2
- 5.33.1+ds+~cs5.3.0-3
- Затронутые диапазоны версий
- ECOSYSTEM: < 5.33.1+ds+~cs5.3.0-4
Обновитесь до 5.33.1+ds+~cs5.3.0-4
vega npm
- Затронутые диапазоны версий
- SEMVER: < 6.2.0
Обновитесь до 6.2.0
vega-expression npm
- Затронутые диапазоны версий
- SEMVER: ≥ 6.0.0, < 6.1.0
Обновитесь до 6.1.0
vega-interpreter npm
- Затронутые диапазоны версий
- SEMVER: ≥ 2.0.0, < 2.2.1
Обновитесь до 2.2.1
vega-interpreter npm
- Затронутые диапазоны версий
- SEMVER: < 1.2.1
Обновитесь до 1.2.1
vega-expression npm
- Затронутые диапазоны версий
- SEMVER: < 5.2.1
Обновитесь до 5.2.1
vega.js Ubuntu 24.04 LTS
- Версии
- 5.25.0+ds+~cs5.3.0-2
- 5.25.0+ds+~cs5.3.0-5
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
vega.js Ubuntu 25.10
- Версии
- 5.28.0+ds+~cs5.3.0-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
vega.js Ubuntu 26.10
- Версии
- 5.28.0+ds+~cs5.3.0-2
- 5.33.1+ds+~cs5.3.0-4
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
vega.js Ubuntu 26.04 LTS
- Версии
- 5.28.0+ds+~cs5.3.0-1
- 5.28.0+ds+~cs5.3.0-2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления