CVE-2025-59845
CVE-2025-59845 · Apollo Embedded Sandbox and Explorer vulnerable to CSRF via window.postMessage origin-validation bypass
CVSS 8.2 · Высокий · EPSS 0,2% · Есть исправление
Затронуты ли вы?
- embeddable-explorerНет опубликованного исправления
- @apollo/sandbox npmОбновитесь до 2.7.2
- @apollo/explorer npmОбновитесь до 3.7.3
Как узнать установленную версию:
npm ls @apollo/sandboxnpm ls @apollo/explorerБесплатная проверка покажет рейтинг сервера и подсветит, требует ли внимания embeddable-explorer и остальные программы. Без регистрации; имена серверов и IP-адреса не отправляются. Номера CVE, версии исправлений и рекомендации — в платном мониторинге.
curl -fsSL https://ru.patchfirst.dev/check.sh | shЗдесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Apollo Studio Embeddable Explorer & Embeddable Sandbox are website embeddable software solutions from Apollo GraphQL. Prior to Apollo Sandbox version 2.7.2 and Apollo Explorer version 3.7.3, a cross-site request forgery (CSRF) vulnerability was identified. The vulnerability arises from missing origin validation in the client-side code that handles window.postMessage events. A malicious website can send forged messages to the embedding page, causing the victim’s browser to execute arbitrary GraphQL queries or mutations against their GraphQL server while authenticated with the victim’s cookies. This issue has been patched in Apollo Sandbox version 2.7.2 and Apollo Explorer version 3.7.3.
- Опубликовано
- Обновлено
Стек: node
Затронутые продукты и версии
embeddable-explorer
- Версии
- < 2.7.2: Затронуто
- < 3.7.3: Затронуто
Нет опубликованного исправления
@apollo/sandbox npm
- Затронутые диапазоны версий
- SEMVER: < 2.7.2
Обновитесь до 2.7.2
@apollo/explorer npm
- Затронутые диапазоны версий
- SEMVER: < 3.7.3
Обновитесь до 3.7.3