CVE-2025-61622
CVE-2025-61622 · Apache Fory, Apache Fory: Python RCE via unguarded pickle fallback serializer in pyfory
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Deserialization of untrusted data in python in pyfory versions 0.12.0 through 0.12.2, or the legacy pyfury versions from 0.1.0 through 0.10.3: allows arbitrary code execution. An application is vulnerable if it reads pyfory serialized data from untrusted sources. An attacker can craft a data stream that selects pickle-fallback serializer during deserialization, leading to the execution of `pickle.loads`, which is vulnerable to remote code execution. Users are recommended to upgrade to pyfory version 0.12.3 or later, which has removed pickle fallback serializer and thus fixes this issue.
CVSS 9.8 · Критический · EPSS 45,1% · Есть исправление
- Опубликовано
- Обновлено
Стек: python
Затронутые продукты и версии
apache fory
- Версии
- ≥ 0.12.0, ≤ 0.12.2: Затронуто (semver)
Нет опубликованного исправления
apache fory
- Версии
- ≥ 0.1.0, ≤ 0.10.3: Затронуто (semver)
Нет опубликованного исправления
pyfory PyPI
- Версии
- 0.12.0
- 0.12.1
- 0.12.2
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 0.12.0, < 0.12.3
Обновитесь до 0.12.3
pyfury PyPI
- Версии
- 0.10.2
- 0.10.2rc1
- 0.10.3
- 0.2.0
- 0.2.0a1
- 0.2.1
- 0.2.1a1
- 0.3.0
- 0.3.0a1
- 0.3.0a2
- 0.3.0a3
- 0.3.1
- 0.4.0
- 0.4.1
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 0.1.0, ≤ 0.10.3
Нет опубликованного исправления