p PatchFirst

CVE-2025-6167

CVE-2025-6167 · themanojdesai python-a2a api.py create_workflow path traversal

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

A vulnerability classified as critical has been found in themanojdesai python-a2a up to 0.5.5. Affected is the function create_workflow of the file python_a2a/agent_flow/server/api.py. The manipulation leads to path traversal. Upgrading to version 0.5.6 is able to address this issue. It is recommended to upgrade the affected component.

CVSS 5.1 · Средний · EPSS 0,8% · Есть исправление

Опубликовано
Обновлено

Стек: python

Затронутые продукты и версии

  • python-a2a

    Версии
    • 0.5.0: Затронуто
    • 0.5.1: Затронуто
    • 0.5.2: Затронуто
    • 0.5.3: Затронуто
    • 0.5.4: Затронуто
    • 0.5.5: Затронуто
    • 0.5.6: Не затронуто

    Обновитесь до 0.5.6

  • python-a2a PyPI

    Версии
    • 0.1.0
    • 0.1.1
    • 0.1.2
    • 0.1.3
    • 0.2.0
    • 0.3.0
    • 0.3.1
    • 0.3.2
    • 0.3.3
    • 0.4.0
    • 0.4.1
    • 0.4.2
    • 0.4.3
    • 0.4.3a0
    • 0.4.4
    • 0.4.5
    • 0.4.6
    • 0.5.0
    • 0.5.1
    • 0.5.2
    • 0.5.3
    • 0.5.4
    • 0.5.5
    Затронутые диапазоны версий
    • ECOSYSTEM: < 0.5.6

    Обновитесь до 0.5.6

  • python-a2a PyPI

    Версии
    • 0.1.0
    • 0.1.1
    • 0.1.2
    • 0.1.3
    • 0.2.0
    • 0.3.0
    • 0.3.1
    • 0.3.2
    • 0.3.3
    • 0.4.0
    • 0.4.1
    • 0.4.2
    • 0.4.3
    • 0.4.3a0
    • 0.4.4
    • 0.4.5
    • 0.4.6
    • 0.5.0
    • 0.5.1
    • 0.5.2
    • 0.5.3
    • 0.5.4
    • 0.5.5
    • v0.5.5
    • v0.5.4
    • v0.5.3
    • v0.5.2
    • v0.5.1
    • v0.5.0
    • v0.4.6
    • v0.4.5
    • v0.4.4
    • v0.4.3a
    • v0.4.3
    Затронутые диапазоны версий
    • GIT: < f486b53625698b7d03561d176dfe98f5d1528276
    • ECOSYSTEM: < 0.5.6

    Обновитесь до 0.5.6

Первоисточники

Проверьте свой сервер →