CVE-2025-6209
CVE-2025-6209 · Arbitrary File Read through Path Traversal in run-llama/llama_index
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
A path traversal vulnerability exists in run-llama/llama_index versions 0.12.27 through 0.12.40, specifically within the `encode_image` function in `generic_utils.py`. This vulnerability allows an attacker to manipulate the `image_path` input to read arbitrary files on the server, including sensitive system files. The issue arises due to improper validation or sanitization of the file path, enabling path traversal sequences to access files outside the intended directory. The vulnerability is fixed in version 0.12.41.
CVSS 7.5 · Высокий · EPSS 0,6% · Есть исправление
- Опубликовано
- Обновлено
Стек: python
Затронутые продукты и версии
run-llama/llama_index
- Версии
- ≥ unspecified, < 0.12.41: Затронуто (custom)
Обновитесь до 0.12.41
llama-index-core PyPI
- Версии
- 0.11.23
- 0.12.0
- 0.12.1
- 0.12.10
- 0.12.10.post1
- 0.12.11
- 0.12.12
- 0.12.13
- 0.12.14
- 0.12.15
- 0.12.16
- 0.12.16.post1
- 0.12.17
- 0.12.18
- 0.12.19
- 0.12.2
- 0.12.20
- 0.12.21
- 0.12.22
- 0.12.23
- 0.12.23.post1
- 0.12.23.post2
- 0.12.24
- 0.12.24.post1
- 0.12.25
- 0.12.26
- 0.12.27
- 0.12.27a1
- 0.12.27a2
- 0.12.27a3
- 0.12.28
- 0.12.29
- 0.12.3
- 0.12.30
- 0.12.31
- 0.12.32
- 0.12.33
- 0.12.33.post1
- 0.12.34
- 0.12.34.post1
- 0.12.34a1
- 0.12.34a2
- 0.12.34a3
- 0.12.34a4
- 0.12.34a5
- 0.12.35
- 0.12.36
- 0.12.37
- 0.12.38
- 0.12.39
- 0.12.4
- 0.12.40
- 0.12.5
- 0.12.6
- 0.12.7
- 0.12.8
- 0.12.9
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 0.11.23, < 0.12.41
Обновитесь до 0.12.41
llama-index PyPI
- Версии
- 0.12.27
- 0.12.28
- 0.12.29
- 0.12.30
- 0.12.31
- 0.12.32
- 0.12.33
- 0.12.34
- 0.12.35
- 0.12.36
- 0.12.37
- 0.12.38
- 0.12.39
- 0.12.40
- Затронутые диапазоны версий
- GIT: < cdeaab91a204d1c3527f177dac37390327aef274
- ECOSYSTEM: ≥ 0.12.27, < 0.12.41
Обновитесь до 0.12.41