CVE-2025-62291
CVE-2025-62291
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
In the eap-mschapv2 plugin (client-side) in strongSwan before 6.0.3, a malicious EAP-MSCHAPv2 server can send a crafted message of size 6 through 8, and cause an integer underflow that potentially results in a heap-based buffer overflow.
CVSS 8.1 · Высокий · EPSS 1,0% · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
strongswan
- Версии
- ≥ 4.2.12, < 6.0.3: Затронуто (semver)
Обновитесь до 6.0.3
strongswan Debian:12
- Версии
- 5.9.8-5
- 5.9.8-5+deb12u1
- Затронутые диапазоны версий
- ECOSYSTEM: < 5.9.8-5+deb12u2
Обновитесь до 5.9.8-5+deb12u2
strongswan Debian:13
- Версии
- 6.0.1-6
- 6.0.1-6+deb13u1
- Затронутые диапазоны версий
- ECOSYSTEM: < 6.0.1-6+deb13u2
Обновитесь до 6.0.1-6+deb13u2
strongswan Debian:14
- Версии
- 6.0.1-6
- 6.0.2-1
- Затронутые диапазоны версий
- ECOSYSTEM: < 6.0.3-1
Обновитесь до 6.0.3-1
strongswan Ubuntu:Pro:14.04:LTS
- Версии
- 4.6.4-9
- 5.1.0-2
- 5.1.0-3
- 5.1.1-0ubuntu1
- 5.1.1-0ubuntu2
- 5.1.1-0ubuntu3
- 5.1.1-0ubuntu4
- 5.1.1-0ubuntu5
- 5.1.1-0ubuntu7
- 5.1.1-0ubuntu14
- 5.1.1-0ubuntu17
- 5.1.2~dr3+git20130120-0ubuntu2
- 5.1.2~dr3+git20130120-0ubuntu3
- 5.1.2~rc1-0ubuntu3
- 5.1.2~rc1-0ubuntu4
- 5.1.2~rc2-0ubuntu2
- 5.1.2-0ubuntu1
- 5.1.2-0ubuntu2
- 5.1.2-0ubuntu2.2
- 5.1.2-0ubuntu2.3
- 5.1.2-0ubuntu2.4
- 5.1.2-0ubuntu2.5
- 5.1.2-0ubuntu2.6
- 5.1.2-0ubuntu2.7
- 5.1.2-0ubuntu2.8
- 5.1.2-0ubuntu2.10
- 5.1.2-0ubuntu2.11
- 5.1.2-0ubuntu2.11+esm1
- 5.1.2-0ubuntu2.11+esm2
- 5.1.2-0ubuntu2.11+esm3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
strongswan Ubuntu:Pro:16.04:LTS
- Версии
- 5.1.2-0ubuntu6
- 5.1.2-0ubuntu7
- 5.1.2-0ubuntu8
- 5.3.5-1ubuntu1
- 5.3.5-1ubuntu2
- 5.3.5-1ubuntu3
- 5.3.5-1ubuntu3.1
- 5.3.5-1ubuntu3.2
- 5.3.5-1ubuntu3.3
- 5.3.5-1ubuntu3.4
- 5.3.5-1ubuntu3.5
- 5.3.5-1ubuntu3.7
- 5.3.5-1ubuntu3.8
- 5.3.5-1ubuntu3.8+esm1
- 5.3.5-1ubuntu3.8+esm2
- 5.3.5-1ubuntu3.8+esm3
- 5.3.5-1ubuntu3.8+esm4
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
strongswan Ubuntu:Pro:FIPS-updates:16.04:LTS
- Версии
- 5.3.5-1ubuntu3.fips.3.4.1
- 5.3.5-1ubuntu3.fips.3.4.2
- 5.3.5-1ubuntu3.fips.3.8.1
- 5.3.5-1ubuntu3.fips.3.8.2
- 5.3.5-1ubuntu3.fips.3.8.3
- 5.3.5-1ubuntu3.fips.3.8.6
- 5.3.5-1ubuntu3.fips.3.8.7
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
strongswan Ubuntu:Pro:FIPS:16.04:LTS
- Версии
- 5.3.5-1ubuntu3.fips.3.1
- 5.3.5-1ubuntu3.fips.3.2
- 5.3.5-1ubuntu3.fips.3.3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
strongswan Ubuntu:Pro:18.04:LTS
- Версии
- 5.5.1-4ubuntu2
- 5.5.1-4ubuntu3
- 5.6.1-2ubuntu1
- 5.6.1-2ubuntu2
- 5.6.1-2ubuntu3
- 5.6.1-2ubuntu4
- 5.6.2-1ubuntu2
- 5.6.2-1ubuntu2.2
- 5.6.2-1ubuntu2.3
- 5.6.2-1ubuntu2.4
- 5.6.2-1ubuntu2.5
- 5.6.2-1ubuntu2.6
- 5.6.2-1ubuntu2.7
- 5.6.2-1ubuntu2.8
- 5.6.2-1ubuntu2.9
- 5.6.2-1ubuntu2.9+esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
strongswan Ubuntu:Pro:FIPS-updates:18.04:LTS
- Версии
- 5.6.2-1ubuntu2.fips.2.5.1
- 5.6.2-1ubuntu2.fips.2.7.1
- 5.6.2-1ubuntu2.fips.2.7.2
- 5.6.2-1ubuntu2.fips.2.8.1
- 5.6.2-1ubuntu2.fips.2.9
- 5.6.2-1ubuntu2.fips.2.9+esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
strongswan Ubuntu:Pro:FIPS:18.04:LTS
- Версии
- 5.6.2-1ubuntu2.fips.2.4.2
- 5.6.2-1ubuntu2.fips.2.5.1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
strongswan Ubuntu:20.04:LTS
- Версии
- 5.7.2-1ubuntu3
- 5.8.1-1ubuntu1
- 5.8.2-1ubuntu1
- 5.8.2-1ubuntu2
- 5.8.2-1ubuntu3
- 5.8.2-1ubuntu3.1
- 5.8.2-1ubuntu3.2
- 5.8.2-1ubuntu3.3
- 5.8.2-1ubuntu3.4
- 5.8.2-1ubuntu3.5
- 5.8.2-1ubuntu3.6
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
strongswan Ubuntu:Pro:FIPS-updates:20.04:LTS
- Версии
- 5.8.2-1ubuntu3.fips.3.1.2
- 5.8.2-1ubuntu3.fips.3.3.1
- 5.8.2-1ubuntu3.fips.3.4.1
- 5.8.2-1ubuntu3.fips.3.5
- 5.8.2-1ubuntu3.fips.3.6
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
strongswan Ubuntu:Pro:FIPS:20.04:LTS
- Версии
- 5.8.2-1ubuntu3.fips.3.1.2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
strongswan Ubuntu:22.04:LTS
- Версии
- 5.9.1-1ubuntu3
- 5.9.1-1ubuntu3.1
- 5.9.4-1ubuntu1
- 5.9.4-1ubuntu2
- 5.9.4-1ubuntu3
- 5.9.4-1ubuntu4
- 5.9.5-2ubuntu1
- 5.9.5-2ubuntu2
- 5.9.5-2ubuntu2.1
- 5.9.5-2ubuntu2.2
- 5.9.5-2ubuntu2.3
- Затронутые диапазоны версий
- ECOSYSTEM: < 5.9.5-2ubuntu2.4
Обновитесь до 5.9.5-2ubuntu2.4
strongswan Ubuntu:Pro:FIPS-preview:22.04:LTS
- Версии
- 5.9.5-2ubuntu2.1+Fips1
- 5.9.5-2ubuntu2.2+Fips1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
strongswan Ubuntu:Pro:FIPS-updates:22.04:LTS
- Версии
- 5.9.5-2ubuntu2.1+Fips1
- 5.9.5-2ubuntu2.2+Fips1
- 5.9.5-2ubuntu2.3+Fips1
- Затронутые диапазоны версий
- ECOSYSTEM: < 5.9.5-2ubuntu2.4+Fips1
Обновитесь до 5.9.5-2ubuntu2.4+Fips1
strongswan Ubuntu:24.04:LTS
- Версии
- 5.9.11-1ubuntu1
- 5.9.11-1ubuntu2
- 5.9.12-1ubuntu1
- 5.9.13-2ubuntu1
- 5.9.13-2ubuntu3
- 5.9.13-2ubuntu4
- Затронутые диапазоны версий
- ECOSYSTEM: < 5.9.13-2ubuntu4.24.04.1
Обновитесь до 5.9.13-2ubuntu4.24.04.1
strongswan Ubuntu:25.10
- Версии
- 5.9.13-2ubuntu4
- 5.9.13-2ubuntu5
- 6.0.1-6ubuntu2
- 6.0.1-6ubuntu4
- Затронутые диапазоны версий
- ECOSYSTEM: < 6.0.1-6ubuntu4.1
Обновитесь до 6.0.1-6ubuntu4.1
strongswan Ubuntu:26.04:LTS
- Версии
- 6.0.1-6ubuntu4
- Затронутые диапазоны версий
- ECOSYSTEM: < 6.0.1-6ubuntu5
Обновитесь до 6.0.1-6ubuntu5
Первоисточники
- https://github.com/strongswan/strongswan/releases
- https://github.com/strongswan/strongswan/commits/master/src/libcharon/plugins/eap_mschapv2
- https://www.strongswan.org/blog/2025/10/27/strongswan-vulnerability-%28cve-2025-62291%29.html
- https://lists.debian.org/debian-lts-announce/2025/11/msg00002.html
- https://nvd.nist.gov/vuln/detail/CVE-2025-62291