CVE-2025-62508
CVE-2025-62508 · Citizen vulnerable to stored XSS in sticky header button messages
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Citizen is a MediaWiki skin that makes extensions part of the cohesive experience. Citizen from 3.3.0 to 3.9.0 are vulnerable to stored cross-site scripting in the sticky header button message handling. In stickyHeader.js the copyButtonAttributes function assigns innerHTML from a source element’s textContent when copying button labels. This causes escaped HTML in system message content (such as citizen-share, citizen-view-history, citizen-view-edit, and nstab-talk) to be interpreted as HTML in the sticky header, allowing injection of arbitrary script by a user with the ability to edit interface messages. The vulnerability allows a user with the editinterface right but without the editsitejs right (by default the sysop group has editinterface but may not have editsitejs) to execute arbitrary JavaScript in other users’ sessions, enabling unauthorized access to sensitive data or actions. The issue is fixed in 3.9.0.
CVSS 6.5 · Средний · EPSS 0,4% · Есть исправление
- Опубликовано
- Обновлено
Стек: php
Затронутые продукты и версии
mediawiki-skins-citizen
- Версии
- >= 3.3.0, < 3.9.0: Затронуто
Нет опубликованного исправления
starcitizentools/citizen-skin Packagist
- Версии
- v3.3.0
- v3.3.1
- v3.3.2
- v3.4.0
- v3.5.0
- v3.6.0
- v3.7.0
- v3.8.0
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 3.3.0, < 3.9.0
Обновитесь до 3.9.0
Первоисточники
- https://github.com/StarCitizenTools/mediawiki-skins-Citizen/security/advisories/GHSA-g955-vw6w-v6pp
- https://github.com/StarCitizenTools/mediawiki-skins-Citizen/commit/e006923c6dbf113c9a025ca186ecc09fe7b93a15
- https://github.com/StarCitizenTools/mediawiki-skins-Citizen/commit/fbb1d4fe9627281567706f3f6fc99a42ce16fdc4
- https://nvd.nist.gov/vuln/detail/CVE-2025-62508