p PatchFirst

CVE-2025-62706

CVE-2025-62706 · Authlib : JWE zip=DEF decompression bomb enables DoS

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Authlib is a Python library which builds OAuth and OpenID Connect servers. Prior to version 1.6.5, Authlib’s JWE zip=DEF path performs unbounded DEFLATE decompression. A very small ciphertext can expand into tens or hundreds of megabytes on decrypt, allowing an attacker who can supply decryptable tokens to exhaust memory and CPU and cause denial of service. This issue has been patched in version 1.6.5. Workarounds for this issue involve rejecting or stripping zip=DEF for inbound JWEs at the application boundary, forking and add a bounded decompression guard via decompressobj().decompress(data, MAX_SIZE)) and returning an error when output exceeds a safe limit, or enforcing strict maximum token sizes and fail fast on oversized inputs; combine with rate limiting.

CVSS 6.5 · Средний · EPSS 0,5% · Есть исправление

Опубликовано
Обновлено

Стек: system · python

Затронутые продукты и версии

  • authlib

    Версии
    • < 1.6.5: Затронуто

    Нет опубликованного исправления

  • python-authlib Debian:12

    Версии
    • 1.2.0-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.2.0-1+deb12u1

    Обновитесь до 1.2.0-1+deb12u1

  • python-authlib Debian:13

    Версии
    • 1.6.0-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.6.0-1+deb13u1

    Обновитесь до 1.6.0-1+deb13u1

  • python-authlib Debian:14

    Версии
    • 1.6.0-1
    • 1.6.1-1
    • 1.6.3-1
    • 1.6.4-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.6.5-1

    Обновитесь до 1.6.5-1

  • authlib PyPI

    Версии
    • 0.1
    • 0.10
    • 0.11
    • 0.12
    • 0.12.1
    • 0.13
    • 0.14
    • 0.14.1
    • 0.14.2
    • 0.14.3
    • 0.15
    • 0.15.1
    • 0.15.2
    • 0.15.3
    • 0.15.4
    • 0.15.5
    • 0.15.6
    • 0.1rc0
    • 0.2
    • 0.2.1
    • 0.3
    • 0.4
    • 0.4.1
    • 0.5
    • 0.5.1
    • 0.6
    • 0.7
    • 0.8
    • 0.9
    • 1.0.0
    • 1.0.0a1
    • 1.0.0a2
    • 1.0.0b1
    • 1.0.0b2
    • 1.0.0rc1
    • 1.0.1
    • 1.1.0
    • 1.2.0
    • 1.2.1
    • 1.3.0
    • 1.3.1
    • 1.3.2
    • 1.4.0
    • 1.4.1
    • 1.5.0
    • 1.5.1
    • 1.5.2
    • 1.6.0
    • 1.6.1
    • 1.6.2
    • 1.6.3
    • 1.6.4
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.6.5

    Обновитесь до 1.6.5

  • python-authlib Ubuntu:Pro:22.04:LTS

    Версии
    • 0.15.4-1
    • 0.15.5-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 0.15.5-1ubuntu0.1~esm1

    Обновитесь до 0.15.5-1ubuntu0.1~esm1

  • python-authlib Ubuntu:Pro:24.04:LTS

    Версии
    • 1.2.1-1
    • 1.3.0-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.3.0-1ubuntu0.1~esm1

    Обновитесь до 1.3.0-1ubuntu0.1~esm1

  • python-authlib Ubuntu:25.10

    Версии
    • 1.5.1-1
    • 1.5.2-1
    • 1.6.0-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • python-authlib Ubuntu:Pro:26.04:LTS

    Версии
    • 1.6.0-1
    • 1.6.5-1
    • 1.6.6-1
    • 1.6.7-1
    • 1.6.7-1ubuntu0.1~esm1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →