CVE-2025-6375
CVE-2025-6375 · poco MultipartReader.cpp MultipartInputStream null pointer dereference
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
A vulnerability was found in poco up to 1.14.1. It has been rated as problematic. Affected by this issue is the function MultipartInputStream of the file Net/src/MultipartReader.cpp. The manipulation leads to null pointer dereference. The attack needs to be approached locally. The exploit has been disclosed to the public and may be used. Upgrading to version 1.14.2 is able to address this issue. The patch is identified as 6f2f85913c191ab9ddfb8fae781f5d66afccf3bf. It is recommended to upgrade the affected component.
CVSS 4.8 · Средний · EPSS 0,3% · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
poco
- Версии
- 1.14.0: Затронуто
- 1.14.1: Затронуто
- 1.14.2: Не затронуто
Обновитесь до 1.14.2
poco Debian:12
- Версии
- 1.11.0-3
- 1.11.0-3+deb12u1
- 1.11.0-3+hurd.1
- 1.11.0-4
- 1.11.0-4.1
- 1.13.0-1
- 1.13.0-2
- 1.13.0-3
- 1.13.0-4
- 1.13.0-5
- 1.13.0-6
- 1.14.2-1
- 1.14.2-2
- 1.14.2-3
- 1.14.2-4
- 1.14.2-5
- 1.14.2-6
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
poco Debian:13
- Версии
- 1.13.0-6
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.13.0-6+deb13u1
Обновитесь до 1.13.0-6+deb13u1
poco Debian:14
- Версии
- 1.13.0-6
- 1.14.2-1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.14.2-2
Обновитесь до 1.14.2-2
poco Ubuntu:14.04:LTS
- Версии
- 1.3.6p1-4
- 1.3.6p1-4+deb7u1build1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
poco Ubuntu:16.04:LTS
- Версии
- 1.3.6p1-5.1
- 1.3.6p1-5.1build1
- 1.3.6p1-5.1ubuntu0.1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
poco Ubuntu:18.04:LTS
- Версии
- 1.7.8+dfsg1-2
- 1.7.8+dfsg1-3
- 1.8.0.1-1ubuntu4
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
poco Ubuntu:20.04:LTS
- Версии
- 1.9.2-3ubuntu2
- 1.9.2-3ubuntu3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
poco Ubuntu:22.04:LTS
- Версии
- 1.10.0-6
- 1.11.0-3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
poco Ubuntu:24.04:LTS
- Версии
- 1.11.0-3
- 1.11.0-4
- 1.11.0-4.1
- 1.11.0-4.1build1
- 1.11.0-4.1build2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
poco Ubuntu:25.10
- Версии
- 1.13.0-6build2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
poco Ubuntu:26.10
- Версии
- 1.14.2-3
- 1.14.2-6
- 1.14.2-6ubuntu1
- 1.14.2-6ubuntu2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
poco Ubuntu:26.04:LTS
- Версии
- 1.13.0-6build2
- 1.14.2-3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
Первоисточники
- https://vuldb.com/?id.313370
- https://vuldb.com/?ctiid.313370
- https://vuldb.com/?submit.597446
- https://github.com/pocoproject/poco/issues/4915
- https://github.com/user-attachments/files/19524599/poco_crash.txt
- https://github.com/pocoproject/poco/commit/6f2f85913c191ab9ddfb8fae781f5d66afccf3bf
- https://github.com/pocoproject/poco/releases/tag/poco-1.14.2-release
- https://nvd.nist.gov/vuln/detail/CVE-2025-6375