p PatchFirst

CVE-2025-6395

CVE-2025-6395 · Gnutls: null pointer dereference in _gnutls_figure_common_ciphersuite()

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

A NULL pointer dereference flaw was found in the GnuTLS software in _gnutls_figure_common_ciphersuite().

CVSS 6.5 · Средний · EPSS 0,8% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • red hat enterprise linux 10

    Версии
    • ≥ 0:3.8.9-9.el10_0.14: Не затронуто (rpm)

    Нет опубликованного исправления

  • red hat enterprise linux 8

    Версии
    • ≥ 0:3.6.16-8.el8_10.4: Не затронуто (rpm)

    Нет опубликованного исправления

  • red hat enterprise linux 9

    Версии
    • ≥ 0:3.8.3-6.el9_6.2: Не затронуто (rpm)

    Нет опубликованного исправления

  • red hat enterprise linux 9.2 update services for sap solutions

    Версии
    • ≥ 0:3.7.6-21.el9_2.4: Не затронуто (rpm)

    Нет опубликованного исправления

  • red hat enterprise linux 9.4 extended update support

    Версии
    • ≥ 0:3.8.3-4.el9_4.4: Не затронуто (rpm)

    Нет опубликованного исправления

  • red hat ceph storage 7

    Версии
    • ≥ 7: Не затронуто (rpm)

    Нет опубликованного исправления

  • red hat discovery 2

    Версии
    • ≥ 2.3.0-1760554384: Не затронуто (rpm)

    Нет опубликованного исправления

  • red hat insights proxy 1.5

    Версии
    • ≥ 1.5.7-1759331989: Не затронуто (rpm)

    Нет опубликованного исправления

  • red hat enterprise linux 6

    Нет опубликованного исправления

  • red hat enterprise linux 7

    Нет опубликованного исправления

  • red hat openshift container platform 4

    Нет опубликованного исправления

  • gnutls28 Debian:12

    Версии
    • 3.7.9-2
    • 3.7.9-2+deb12u1
    • 3.7.9-2+deb12u2
    • 3.7.9-2+deb12u3
    • 3.7.9-2+deb12u4
    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.7.9-2+deb12u5

    Обновитесь до 3.7.9-2+deb12u5

  • gnutls28 Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.8.9-3

    Обновитесь до 3.8.9-3

  • gnutls28 Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.8.9-3

    Обновитесь до 3.8.9-3

  • gnutls28 Ubuntu:Pro:20.04:LTS

    Версии
    • 3.6.9-5ubuntu1
    • 3.6.9-5ubuntu2
    • 3.6.10-5
    • 3.6.11.1-2
    • 3.6.11.1-2ubuntu2
    • 3.6.13-2ubuntu1
    • 3.6.13-2ubuntu1.1
    • 3.6.13-2ubuntu1.2
    • 3.6.13-2ubuntu1.3
    • 3.6.13-2ubuntu1.6
    • 3.6.13-2ubuntu1.7
    • 3.6.13-2ubuntu1.8
    • 3.6.13-2ubuntu1.9
    • 3.6.13-2ubuntu1.10
    • 3.6.13-2ubuntu1.11
    • 3.6.13-2ubuntu1.12
    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.6.13-2ubuntu1.12+esm1

    Обновитесь до 3.6.13-2ubuntu1.12+esm1

  • gnutls28 Ubuntu:22.04:LTS

    Версии
    • 3.7.1-5ubuntu1
    • 3.7.2-2ubuntu1
    • 3.7.2-4ubuntu1
    • 3.7.2-5ubuntu1
    • 3.7.3-4ubuntu1
    • 3.7.3-4ubuntu1.1
    • 3.7.3-4ubuntu1.2
    • 3.7.3-4ubuntu1.3
    • 3.7.3-4ubuntu1.4
    • 3.7.3-4ubuntu1.5
    • 3.7.3-4ubuntu1.6
    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.7.3-4ubuntu1.7

    Обновитесь до 3.7.3-4ubuntu1.7

  • gnutls28 Ubuntu:Pro:FIPS-preview:22.04:LTS

    Версии
    • 3.7.3-4ubuntu1.2+Fips1.1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • gnutls28 Ubuntu:Pro:FIPS-updates:22.04:LTS

    Версии
    • 3.7.3-4ubuntu1.2+Fips1.1
    • 3.7.3-4ubuntu1.3+Fips1.1
    • 3.7.3-4ubuntu1.4+Fips1
    • 3.7.3-4ubuntu1.5+Fips1
    • 3.7.3-4ubuntu1.6+Fips1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.7.3-4ubuntu1.7+Fips1

    Обновитесь до 3.7.3-4ubuntu1.7+Fips1

  • gnutls28 Ubuntu:24.04:LTS

    Версии
    • 3.8.1-4ubuntu1
    • 3.8.1-4ubuntu6
    • 3.8.1-4ubuntu7
    • 3.8.3-1ubuntu1
    • 3.8.3-1.1ubuntu2
    • 3.8.3-1.1ubuntu3
    • 3.8.3-1.1ubuntu3.1
    • 3.8.3-1.1ubuntu3.2
    • 3.8.3-1.1ubuntu3.3
    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.8.3-1.1ubuntu3.4

    Обновитесь до 3.8.3-1.1ubuntu3.4

  • gnutls28 Ubuntu:Pro:FIPS-updates:24.04:LTS

    Версии
    • 3.8.3-1.1ubuntu3.1+Fips1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.8.3-1.1ubuntu3.4+Fips1

    Обновитесь до 3.8.3-1.1ubuntu3.4+Fips1

  • gnutls28 Ubuntu:25.10

    Версии
    • 3.8.9-2ubuntu3
    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.8.9-3ubuntu1

    Обновитесь до 3.8.9-3ubuntu1

Первоисточники

Проверьте свой сервер →