p PatchFirst

CVE-2025-64718

CVE-2025-64718 · js-yaml has prototype pollution in merge (<<)

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

js-yaml is a JavaScript YAML parser and dumper. In js-yaml before 4.1.1 and 3.14.2, it's possible for an attacker to modify the prototype of the result of a parsed yaml document via prototype pollution (`__proto__`). All users who parse untrusted yaml documents may be impacted. The problem is patched in js-yaml 4.1.1 and 3.14.2. Users can protect against this kind of attack on the server by using `node --disable-proto=delete` or `deno` (in Deno, pollution protection is on by default).

CVSS 5.3 · Средний · EPSS 0,4% · Есть исправление

Опубликовано
Обновлено

Стек: system · node

Затронутые продукты и версии

  • js-yaml

    Версии
    • >= 4.0.0, < 4.1.1: Затронуто
    • < 3.14.2: Затронуто

    Нет опубликованного исправления

  • node-js-yaml Debian:12

    Версии
    • 4.1.0+dfsg+~4.0.5-7
    • 4.1.1+dfsg+~4.0.9-1
    • 4.2.0+~4.0.9-1
    • 4.2.0+~4.0.9-2
    • 4.3.2+~4.0.9-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-js-yaml Debian:13

    Версии
    • 4.1.0+dfsg+~4.0.5-7
    • 4.1.1+dfsg+~4.0.9-1
    • 4.2.0+~4.0.9-1
    • 4.2.0+~4.0.9-2
    • 4.3.2+~4.0.9-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-js-yaml Debian:14

    Версии
    • 4.1.0+dfsg+~4.0.5-7
    Затронутые диапазоны версий
    • ECOSYSTEM: < 4.1.1+dfsg+~4.0.9-1

    Обновитесь до 4.1.1+dfsg+~4.0.9-1

  • js-yaml npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 4.0.0, < 4.1.1

    Обновитесь до 4.1.1

  • js-yaml npm

    Затронутые диапазоны версий
    • SEMVER: < 3.14.2

    Обновитесь до 3.14.2

  • node-js-yaml Ubuntu:18.04:LTS

    Версии
    • 3.9.1+dfsg-1
    • 3.10.0+dfsg-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-js-yaml Ubuntu:20.04:LTS

    Версии
    • 3.13.1+dfsg-2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-js-yaml Ubuntu:22.04:LTS

    Версии
    • 3.14.1+dfsg+~3.12.6-2
    • 4.1.0+dfsg+~4.0.5-4ubuntu1
    • 4.1.0+dfsg+~4.0.5-5
    • 4.1.0+dfsg+~4.0.5-6
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-js-yaml Ubuntu:24.04:LTS

    Версии
    • 4.1.0+dfsg+~4.0.5-7
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-js-yaml Ubuntu:25.10

    Версии
    • 4.1.0+dfsg+~4.0.5-7
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-js-yaml Ubuntu:26.10

    Версии
    • 4.1.1+dfsg+~4.0.9-1
    • 4.2.0+~4.0.9-1
    • 4.2.0+~4.0.9-2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-js-yaml Ubuntu:26.04:LTS

    Версии
    • 4.1.0+dfsg+~4.0.5-7
    • 4.1.1+dfsg+~4.0.9-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →