CVE-2025-66412
CVE-2025-66412 · Angular Stored XSS Vulnerability via SVG Animation, SVG URL and MathML Attributes
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 21.0.2, 20.3.15, and 19.2.17, A Stored Cross-Site Scripting (XSS) vulnerability has been identified in the Angular Template Compiler. It occurs because the compiler's internal security schema is incomplete, allowing attackers to bypass Angular's built-in security sanitization. Specifically, the schema fails to classify certain URL-holding attributes (e.g., those that could contain javascript: URLs) as requiring strict URL security, enabling the injection of malicious scripts. This vulnerability is fixed in 21.0.2, 20.3.15, and 19.2.17.
CVSS 8.5 · Высокий · EPSS 0,4% · Есть исправление
- Опубликовано
- Обновлено
Затронутые продукты и версии
angular
- Версии
- >= 21.0.0-next.0 < 21.0.2: Затронуто
- >= 20.0.0-next.0 < 20.3.15: Затронуто
- >= 19.0.0-next.0 < 19.2.17: Затронуто
- <= 18.2.14: Затронуто
Нет опубликованного исправления
@angular/compiler npm
- Затронутые диапазоны версий
- SEMVER: ≥ 21.0.0-next.0, < 21.0.2
Обновитесь до 21.0.2
@angular/compiler npm
- Затронутые диапазоны версий
- SEMVER: ≥ 20.0.0-next.0, < 20.3.15
Обновитесь до 20.3.15
@angular/compiler npm
- Затронутые диапазоны версий
- SEMVER: ≥ 19.0.0-next.0, < 19.2.17
Обновитесь до 19.2.17
@angular/compiler npm
- Затронутые диапазоны версий
- SEMVER: ≤ 18.2.14
Нет опубликованного исправления
angular.js Ubuntu:Pro:16.04:LTS
- Версии
- 1.2.28-1ubuntu2
- 1.2.28-1ubuntu2+esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
angular.js Ubuntu:Pro:18.04:LTS
- Версии
- 1.5.10-1
- 1.5.10-1ubuntu0.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
angular.js Ubuntu:Pro:20.04:LTS
- Версии
- 1.5.10-1
- 1.7.9-1
- 1.7.9-1ubuntu0.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
angular.js Ubuntu:22.04:LTS
- Версии
- 1.8.2-2
- 1.8.2-2ubuntu0.1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
angular.js Ubuntu:24.04:LTS
- Версии
- 1.8.3-1
- 1.8.3-1ubuntu0.24.04.1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
angular.js Ubuntu:25.10
- Версии
- 1.8.3-1
- 1.8.3-3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
angular.js Ubuntu:26.10
- Версии
- 1.8.3-3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
angular.js Ubuntu:26.04:LTS
- Версии
- 1.8.3-3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
Первоисточники
- https://github.com/angular/angular/security/advisories/GHSA-v4hv-rgfq-gp49
- https://github.com/angular/angular/commit/1c6b0704fb63d051fab8acff84d076abfbc4893a
- https://cert-portal.siemens.com/productcert/html/ssa-485750.html
- https://cert-portal.siemens.com/productcert/html/ssa-253495.html
- https://nvd.nist.gov/vuln/detail/CVE-2025-66412