CVE-2025-66648
CVE-2025-66648 · `vega-functions` vulnerable to Cross-site Scripting via `setdata` function
CVSS 7.2 · Высокий · EPSS 0,2% · Есть исправление
Затронуты ли вы?
- vegaНет опубликованного исправления
- vega.js Debian 12Нет опубликованного исправления
- vega.js Debian 13Нет опубликованного исправления
- vega.js Debian 14Обновитесь до 5.33.1+ds+~cs5.3.0-2
- и ещё 5
Как узнать установленную версию:
dpkg-query -W -f='${source:Package} ${binary:Package} ${Version}\n' | awk '$1=="vega.js"'Бесплатная проверка покажет рейтинг сервера и подсветит, требует ли внимания vega и остальные программы. Без регистрации; имена серверов и IP-адреса не отправляются. Номера CVE, версии исправлений и рекомендации — в платном мониторинге.
curl -fsSL https://ru.patchfirst.dev/check.sh | shЗдесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
vega-functions provides function implementations for the Vega expression language. Prior to version 6.1.1, for sites that allow users to supply untrusted user input, malicious use of an internal function (not part of the public API) could be used to run unintentional javascript (XSS). This issue is fixed in vega-functions `6.1.1`. There is no workaround besides upgrading. Using `vega.expressionInterpreter` as described in CSP safe mode does not prevent this issue.
- Опубликовано
- Обновлено
Затронутые продукты и версии
vega
- Версии
- < 6.1.1: Затронуто
Нет опубликованного исправления
vega.js Debian 12
- Версии
- 5.22.1+ds+~3.1.0-4
- 5.25.0+ds+~cs5.3.0-1
- 5.25.0+ds+~cs5.3.0-2
- 5.25.0+ds+~cs5.3.0-3
- 5.25.0+ds+~cs5.3.0-4
- 5.25.0+ds+~cs5.3.0-5
Все версии (13)
- 5.28.0+ds+~cs5.3.0-1
- 5.28.0+ds+~cs5.3.0-2
- 5.28.0+ds+~cs5.3.0-3
- 5.33.1+ds+~cs5.3.0-1
- 5.33.1+ds+~cs5.3.0-2
- 5.33.1+ds+~cs5.3.0-3
- 5.33.1+ds+~cs5.3.0-4
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
vega.js Debian 13
- Версии
- 5.28.0+ds+~cs5.3.0-1
- 5.28.0+ds+~cs5.3.0-2
- 5.28.0+ds+~cs5.3.0-3
- 5.33.1+ds+~cs5.3.0-1
- 5.33.1+ds+~cs5.3.0-2
- 5.33.1+ds+~cs5.3.0-3
Все версии (7)
- 5.33.1+ds+~cs5.3.0-4
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
vega.js Debian 14
- Версии
- 5.28.0+ds+~cs5.3.0-1
- 5.28.0+ds+~cs5.3.0-2
- 5.28.0+ds+~cs5.3.0-3
- 5.33.1+ds+~cs5.3.0-1
- Затронутые диапазоны версий
- ECOSYSTEM: < 5.33.1+ds+~cs5.3.0-2
Обновитесь до 5.33.1+ds+~cs5.3.0-2
vega-functions npm
- Затронутые диапазоны версий
- SEMVER: < 6.1.1
Обновитесь до 6.1.1
vega.js Ubuntu 24.04 LTS
- Версии
- 5.25.0+ds+~cs5.3.0-2
- 5.25.0+ds+~cs5.3.0-5
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
vega.js Ubuntu 25.10
- Версии
- 5.28.0+ds+~cs5.3.0-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
vega.js Ubuntu 26.10
- Версии
- 5.28.0+ds+~cs5.3.0-2
- 5.33.1+ds+~cs5.3.0-4
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
vega.js Ubuntu 26.04 LTS
- Версии
- 5.28.0+ds+~cs5.3.0-1
- 5.28.0+ds+~cs5.3.0-2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления