CVE-2025-67647
CVE-2025-67647 · SvelteKit Denial of service and possible SSRF when using prerendering
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
SvelteKit is a framework for rapidly developing robust, performant web applications using Svelte. Prior to 2.49.5, SvelteKit is vulnerable to a server side request forgery (SSRF) and denial of service (DoS) under certain conditions. From 2.44.0 through 2.49.4, the vulnerability results in a DoS when your app has at least one prerendered route (export const prerender = true). From 2.19.0 through 2.49.4, the vulnerability results in a DoS when your app has at least one prerendered route and you are using adapter-node without a configured ORIGIN environment variable, and you are not using a reverse proxy that implements Host header validation. This vulnerability is fixed in 2.49.5.
CVSS 8.4 · Высокий · EPSS 0,5% · Есть исправление
- Опубликовано
- Обновлено
Стек: node
Затронутые продукты и версии
kit
- Версии
- >= 2.19.0, < 2.49.5: Затронуто
Нет опубликованного исправления
@sveltejs/kit npm
- Затронутые диапазоны версий
- SEMVER: ≥ 2.19.0, < 2.49.5
Обновитесь до 2.49.5
@sveltejs/adapter-node npm
- Затронутые диапазоны версий
- SEMVER: ≥ 5.4.1, < 5.5.1
Обновитесь до 5.5.1