CVE-2025-67716
CVE-2025-67716 · Auth0 Next.js SDK has Improper Validation of Query Parameters
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions 4.9.0 through 4.12.1 contain an input-validation flaw in the returnTo parameter, which could allow attackers to inject unintended OAuth query parameters into the Auth0 authorization request. Successful exploitation may result in tokens being issued with unintended parameters. This issue is fixed in version 4.13.0.
CVSS 5.7 · Средний · EPSS 0,3% · Есть исправление
- Опубликовано
- Обновлено
Стек: node
Затронутые продукты и версии
nextjs-auth0
- Версии
- >= 4.9.0, < 4.13.0: Затронуто
Нет опубликованного исправления
@auth0/nextjs-auth0 npm
- Затронутые диапазоны версий
- SEMVER: ≥ 4.9.0, < 4.13.0
Обновитесь до 4.13.0