CVE-2025-67729
CVE-2025-67729 · lmdeploy vulnerable to Arbitrary Code Execution via Insecure Deserialization in torch.load()
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
LMDeploy is a toolkit for compressing, deploying, and serving LLMs. Prior to version 0.11.1, an insecure deserialization vulnerability exists in lmdeploy where torch.load() is called without the weights_only=True parameter when loading model checkpoint files. This allows an attacker to execute arbitrary code on the victim's machine when they load a malicious .bin or .pt model file. This issue has been patched in version 0.11.1.
CVSS 8.8 · Высокий · EPSS 0,5% · Есть исправление
- Опубликовано
- Обновлено
Стек: python
Затронутые продукты и версии
lmdeploy
- Версии
- < 0.11.1: Затронуто
Нет опубликованного исправления
lmdeploy PyPI
- Версии
- 0.0.10
- 0.0.11
- 0.0.12
- 0.0.13
- 0.0.14
- 0.1.0
- 0.10.0
- 0.10.1
- 0.10.2
- 0.11.0
- 0.2.0
- 0.2.1
- 0.2.2
- 0.2.3
- 0.2.4
- 0.2.5
- 0.2.6
- 0.3.0
- 0.4.0
- 0.4.1
- 0.4.2
- 0.5.0
- 0.5.1
- 0.5.2
- 0.5.2.post1
- 0.5.3
- 0.6.0
- 0.6.0a0
- 0.6.1
- 0.6.2
- 0.6.2.post1
- 0.6.3
- 0.6.4
- 0.6.5
- 0.7.0
- 0.7.0.post1
- 0.7.0.post2
- 0.7.0.post3
- 0.7.1
- 0.7.2
- 0.7.2.post1
- 0.7.3
- 0.8.0
- 0.9.0
- 0.9.1
- 0.9.2
- 0.9.2.post1
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.11.1
Обновитесь до 0.11.1