p PatchFirst

CVE-2025-68158

CVE-2025-68158 · Authlib: 1-click Account Takeover

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Authlib is a Python library which builds OAuth and OpenID Connect servers. In versions 1.0.0 through 1.6.5, cache-backed state/request-token storage is not tied to the initiating user session, so CSRF is possible for any attacker that has a valid state (easily obtainable via an attacker-initiated authentication flow). When a cache is supplied to the OAuth client registry, FrameworkIntegration.set_state_data writes the entire state blob under _state_{app}_{state}, and get_state_data ignores the caller’s session altogether. This issue has been patched in version 1.6.6.

CVSS 5.7 · Средний · EPSS 0,3% · Есть исправление

Опубликовано
Обновлено

Стек: system · python

Затронутые продукты и версии

  • authlib

    Версии
    • >= 1.0.0, < 1.6.6: Затронуто

    Нет опубликованного исправления

  • python-authlib Debian:12

    Версии
    • 1.2.0-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.2.0-1+deb12u1

    Обновитесь до 1.2.0-1+deb12u1

  • python-authlib Debian:13

    Версии
    • 1.6.0-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.6.0-1+deb13u1

    Обновитесь до 1.6.0-1+deb13u1

  • python-authlib Debian:14

    Версии
    • 1.6.0-1
    • 1.6.1-1
    • 1.6.3-1
    • 1.6.4-1
    • 1.6.5-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.6.6-1

    Обновитесь до 1.6.6-1

  • authlib PyPI

    Версии
    • 1.0.0
    • 1.0.1
    • 1.1.0
    • 1.2.0
    • 1.2.1
    • 1.3.0
    • 1.3.1
    • 1.3.2
    • 1.4.0
    • 1.4.1
    • 1.5.0
    • 1.5.1
    • 1.5.2
    • 1.6.0
    • 1.6.1
    • 1.6.2
    • 1.6.3
    • 1.6.4
    • 1.6.5
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 1.0.0, < 1.6.6

    Обновитесь до 1.6.6

  • python-authlib Ubuntu:Pro:24.04:LTS

    Версии
    • 1.2.1-1
    • 1.3.0-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.3.0-1ubuntu0.1~esm1

    Обновитесь до 1.3.0-1ubuntu0.1~esm1

  • python-authlib Ubuntu:25.10

    Версии
    • 1.5.1-1
    • 1.5.2-1
    • 1.6.0-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →