CVE-2025-68617
CVE-2025-68617 · Use after free in fluidsynth
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
FluidSynth is a software synthesizer based on the SoundFont 2 specifications. From versions 2.5.0 to before 2.5.2, a race condition during unloading of a DLS file can trigger a heap-based use-after-free. A concurrently running thread may be pending to unload a DLS file, leading to use of freed memory, if the synthesizer is being concurrently destroyed, or samples of the (unloaded) DLS file are concurrently used to synthesize audio. This issue has been patched in version 2.5.2. The problem will not occur, when explicitly unloading a DLS file (before synth destruction), provided that at the time of unloading, no samples of the respective file are used by active voices. The problem will not occur in versions of FluidSynth that have been compiled without native DLS support.
CVSS 7.0 · Высокий · EPSS 0,2% · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
fluidsynth
- Версии
- >= 2.5.0, < 2.5.2: Затронуто
Нет опубликованного исправления
fluidsynth Debian:14
- Версии
- 2.4.4+dfsg-1
- 2.4.6+dfsg-1
- 2.4.7+dfsg-1
- 2.4.7+dfsg-2
- 2.4.8+dfsg-1
- 2.5.0+dfsg-1
- 2.5.1+dfsg-1
- 2.5.1+dfsg-2
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.5.2+dfsg-1
Обновитесь до 2.5.2+dfsg-1
fluidsynth Ubuntu:Pro:14.04:LTS
- Версии
- 1.1.6-2
- 1.1.6-2ubuntu0.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
fluidsynth Ubuntu:Pro:16.04:LTS
- Версии
- 1.1.6-2build1
- 1.1.6-3
- 1.1.6-3ubuntu0.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
fluidsynth Ubuntu:Pro:18.04:LTS
- Версии
- 1.1.6-4
- 1.1.8-1
- 1.1.8-2
- 1.1.8-3
- 1.1.9-1
- 1.1.9-1ubuntu0.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
fluidsynth Ubuntu:Pro:20.04:LTS
- Версии
- 1.1.11-4
- 1.1.11-4ubuntu1
- 2.1.0-1
- 2.1.1-2
- 2.1.1-2ubuntu0.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
fluidsynth Ubuntu:Pro:22.04:LTS
- Версии
- 2.1.7-1.1
- 2.2.4-2
- 2.2.5-1
- 2.2.5-1ubuntu0.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
fluidsynth Ubuntu:Pro:24.04:LTS
- Версии
- 2.3.3-2.1
- 2.3.4-1
- 2.3.4-1build1
- 2.3.4-1build2
- 2.3.4-1build3
- 2.3.4-1ubuntu0.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
fluidsynth Ubuntu:25.10
- Версии
- 2.4.4+dfsg-1
- 2.4.7+dfsg-1
- 2.4.7+dfsg-2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
fluidsynth Ubuntu:26.10
- Версии
- 2.4.8+dfsg-1
- 2.5.6+dfsg-1
- 2.5.7+dfsg-1
- 2.6.0+dfsg-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
fluidsynth Ubuntu:Pro:26.04:LTS
- Версии
- 2.4.7+dfsg-2
- 2.4.8+dfsg-1
- 2.4.8+dfsg-1ubuntu0.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
Первоисточники
- https://github.com/FluidSynth/fluidsynth/security/advisories/GHSA-ffw2-xvvp-39ch
- https://github.com/FluidSynth/fluidsynth/issues/1717
- https://github.com/FluidSynth/fluidsynth/issues/1728
- https://github.com/FluidSynth/fluidsynth/commit/685e54cdc44911ace31774260bd0c9ec89887491
- https://github.com/FluidSynth/fluidsynth/commit/962b9946b5cb6b16f0c08b89dd1b7016d4fce886
- https://nvd.nist.gov/vuln/detail/CVE-2025-68617