p PatchFirst

CVE-2025-68665

CVE-2025-68665 · LangChain serialization injection vulnerability enables secret extraction

CVSS 8.6 · Высокий · EPSS 0,8% · Есть исправление

Затронуты ли вы?

Как узнать установленную версию:

npm ls @langchain/core
npm ls langchain

Бесплатная проверка покажет рейтинг сервера и подсветит, требует ли внимания langchainjs и остальные программы. Без регистрации; имена серверов и IP-адреса не отправляются. Номера CVE, версии исправлений и рекомендации — в платном мониторинге.

curl -fsSL https://ru.patchfirst.dev/check.sh | sh
Проверить сервер бесплатно →

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

LangChain is a framework for building LLM-powered applications. Prior to @langchain/core versions 0.3.80 and 1.1.8, and prior to langchain versions 0.3.37 and 1.2.3, a serialization injection vulnerability exists in LangChain JS's toJSON() method (and subsequently when string-ifying objects using JSON.stringify(). The method did not escape objects with 'lc' keys when serializing free-form data in kwargs. The 'lc' key is used internally by LangChain to mark serialized objects. When user-controlled data contains this key structure, it is treated as a legitimate LangChain object during deserialization rather than plain user data. This issue has been patched in @langchain/core versions 0.3.80 and 1.1.8, and langchain versions 0.3.37 and 1.2.3

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • langchainjs

    Версии
    • @langchain/core >= 1.0.0, < 1.1.8: Затронуто
    • @langchain/core < 0.3.80: Затронуто
    • langchain >= 1.0.0, < 1.2.3: Затронуто
    • langchain < 0.3.37: Затронуто

    Нет опубликованного исправления

  • @langchain/core npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 1.0.0, < 1.1.8

    Обновитесь до 1.1.8

  • @langchain/core npm

    Затронутые диапазоны версий
    • SEMVER: < 0.3.80

    Обновитесь до 0.3.80

  • langchain npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 1.0.0, < 1.2.3

    Обновитесь до 1.2.3

  • langchain npm

    Затронутые диапазоны версий
    • SEMVER: < 0.3.37

    Обновитесь до 0.3.37

Первоисточники

Проверьте свой сервер →