p PatchFirst

CVE-2025-69262

CVE-2025-69262 · pnpm vulnerable to Command Injection via environment variable substitution

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

pnpm is a package manager. Versions 6.25.0 through 10.26.2 have a Command Injection vulnerability when using environment variable substitution in .npmrc configuration files with tokenHelper settings. An attacker who can control environment variables during pnpm operations could achieve Remote Code Execution (RCE) in build environments. This issue is fixed in version 10.27.0.

CVSS 7.6 · Высокий · EPSS 1,0% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • pnpm

    Версии
    • >=6.25.0, < 10.27.0: Затронуто

    Нет опубликованного исправления

  • pnpm npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 6.25.0, < 10.27.0

    Обновитесь до 10.27.0

Первоисточники

Проверьте свой сервер →