CVE-2025-6965
CVE-2025-6965 · Integer Truncation on SQLite
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
There exists a vulnerability in SQLite versions before 3.50.2 where the number of aggregate terms could exceed the number of columns available. This could lead to a memory corruption issue. We recommend upgrading to version 3.50.2 or above.
CVSS 7.2 · Высокий · EPSS 73,5% · Публичный эксплойт · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
sqlite
- Версии
- ≥ 0, < 3.50.2: Затронуто (semver)
Обновитесь до 3.50.2
sqlite3 Debian:12
- Версии
- 3.40.1-2
- 3.40.1-2+deb12u1
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.40.1-2+deb12u2
Обновитесь до 3.40.1-2+deb12u2
sqlite3 Debian:13
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.46.1-7
Обновитесь до 3.46.1-7
sqlite3 Debian:14
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.46.1-7
Обновитесь до 3.46.1-7
sqlite3 Ubuntu:Pro:14.04:LTS
- Версии
- 3.7.17-1ubuntu1
- 3.8.0.2-1ubuntu1
- 3.8.1-1ubuntu1
- 3.8.1-1ubuntu3
- 3.8.2-1ubuntu1
- 3.8.2-1ubuntu2
- 3.8.2-1ubuntu2.1
- 3.8.2-1ubuntu2.2
- 3.8.2-1ubuntu2.2+esm1
- 3.8.2-1ubuntu2.2+esm2
- 3.8.2-1ubuntu2.2+esm3
- 3.8.2-1ubuntu2.2+esm4
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.8.2-1ubuntu2.2+esm5
Обновитесь до 3.8.2-1ubuntu2.2+esm5
sqlite3 Ubuntu:Pro:16.04:LTS
- Версии
- 3.8.11.1-1
- 3.9.1-2
- 3.9.2-1
- 3.10.0-1
- 3.10.1-1
- 3.10.2-1
- 3.11.0-1ubuntu1
- 3.11.0-1ubuntu1.1
- 3.11.0-1ubuntu1.2
- 3.11.0-1ubuntu1.3
- 3.11.0-1ubuntu1.4
- 3.11.0-1ubuntu1.5
- 3.11.0-1ubuntu1.5+esm1
- 3.11.0-1ubuntu1.5+esm2
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.11.0-1ubuntu1.5+esm3
Обновитесь до 3.11.0-1ubuntu1.5+esm3
sqlite3 Ubuntu:Pro:18.04:LTS
- Версии
- 3.19.3-3
- 3.20.1-2
- 3.21.0-1
- 3.22.0-1
- 3.22.0-1ubuntu0.1
- 3.22.0-1ubuntu0.2
- 3.22.0-1ubuntu0.3
- 3.22.0-1ubuntu0.4
- 3.22.0-1ubuntu0.5
- 3.22.0-1ubuntu0.6
- 3.22.0-1ubuntu0.7
- 3.22.0-1ubuntu0.7+esm1
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.22.0-1ubuntu0.7+esm2
Обновитесь до 3.22.0-1ubuntu0.7+esm2
sqlite3 Ubuntu:Pro:20.04:LTS
- Версии
- 3.29.0-2
- 3.30.1-1
- 3.30.1-1ubuntu1
- 3.31.1-1ubuntu1
- 3.31.1-3
- 3.31.1-4
- 3.31.1-4ubuntu0.1
- 3.31.1-4ubuntu0.2
- 3.31.1-4ubuntu0.3
- 3.31.1-4ubuntu0.4
- 3.31.1-4ubuntu0.5
- 3.31.1-4ubuntu0.6
- 3.31.1-4ubuntu0.7
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.31.1-4ubuntu0.7+esm1
Обновитесь до 3.31.1-4ubuntu0.7+esm1
sqlite3 Ubuntu:22.04:LTS
- Версии
- 3.35.5-1
- 3.36.0-2
- 3.37.2-2
- 3.37.2-2ubuntu0.1
- 3.37.2-2ubuntu0.3
- 3.37.2-2ubuntu0.4
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.37.2-2ubuntu0.5
Обновитесь до 3.37.2-2ubuntu0.5
sqlite3 Ubuntu:24.04:LTS
- Версии
- 3.42.0-1
- 3.44.0-1
- 3.44.2-1
- 3.45.0-1
- 3.45.1-1
- 3.45.1-1ubuntu1
- 3.45.1-1ubuntu2
- 3.45.1-1ubuntu2.1
- 3.45.1-1ubuntu2.3
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.45.1-1ubuntu2.4
Обновитесь до 3.45.1-1ubuntu2.4
sqlite3 Ubuntu:25.10
- Версии
- 3.46.1-3
- 3.46.1-4
- 3.46.1-6
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.46.1-6ubuntu1
Обновитесь до 3.46.1-6ubuntu1
Первоисточники
- https://www.sqlite.org/src/info/5508b56fd24016c13981ec280ecdd833007c9d8dd595edb295b984c2b487b5c8
- http://seclists.org/fulldisclosure/2025/Sep/57
- http://seclists.org/fulldisclosure/2025/Sep/56
- http://seclists.org/fulldisclosure/2025/Sep/53
- http://seclists.org/fulldisclosure/2025/Sep/58
- http://seclists.org/fulldisclosure/2025/Sep/49
- http://www.openwall.com/lists/oss-security/2025/09/06/1
- https://cert-portal.siemens.com/productcert/html/ssa-485750.html
- https://cert-portal.siemens.com/productcert/html/ssa-225816.html
- https://cert-portal.siemens.com/productcert/html/ssa-765416.html
- https://nvd.nist.gov/vuln/detail/CVE-2025-6965