CVE-2025-7339
CVE-2025-7339 · on-headers vulnerable to http response header manipulation
CVSS 3.4 · Низкий · EPSS 0,2% · Есть исправление
Затронуты ли вы?
- on-headersОбновитесь до 1.1.0
- node-on-headers Debian 12Нет опубликованного исправления
- node-on-headers Debian 13Обновитесь до 1.0.2-4
- node-on-headers Debian 14Обновитесь до 1.0.2-4
- и ещё 9
Как узнать установленную версию:
dpkg-query -W -f='${source:Package} ${binary:Package} ${Version}\n' | awk '$1=="node-on-headers"'Бесплатная проверка покажет рейтинг сервера и подсветит, требует ли внимания on-headers и остальные программы. Без регистрации; имена серверов и IP-адреса не отправляются. Номера CVE, версии исправлений и рекомендации — в платном мониторинге.
curl -fsSL https://ru.patchfirst.dev/check.sh | shЗдесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
on-headers is a node.js middleware for listening to when a response writes headers. A bug in on-headers versions `<1.1.0` may result in response headers being inadvertently modified when an array is passed to `response.writeHead()`. Users should upgrade to version 1.1.0 to receive a patch. Uses are strongly encouraged to upgrade to `1.1.0`, but this issue can be worked around by passing an object to `response.writeHead()` rather than an array.
- Опубликовано
- Обновлено
Затронутые продукты и версии
on-headers
- Версии
- ≥ 0, < 1.1.0: Затронуто (semver)
Обновитесь до 1.1.0
node-on-headers Debian 12
- Версии
- 1.0.2-2
- 1.0.2-4
- 1.1.0-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-on-headers Debian 13
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.0.2-4
Обновитесь до 1.0.2-4
node-on-headers Debian 14
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.0.2-4
Обновитесь до 1.0.2-4
on-headers npm
- Затронутые диапазоны версий
- SEMVER: < 1.1.0
Обновитесь до 1.1.0
node-on-headers Ubuntu 16.04 LTS
- Версии
- 1.0.0-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-on-headers Ubuntu 18.04 LTS
- Версии
- 1.0.0-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-on-headers Ubuntu 20.04 LTS
- Версии
- 1.0.1-1
- 1.0.2-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-on-headers Ubuntu 22.04 LTS
- Версии
- 1.0.2-1
- 1.0.2-2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-on-headers Ubuntu 24.04 LTS
- Версии
- 1.0.2-2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-on-headers Ubuntu 25.10
- Версии
- 1.0.2-2
- 1.0.2-4
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-on-headers Ubuntu 26.10
- Версии
- 1.0.2-4
- 1.1.0-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-on-headers Ubuntu 26.04 LTS
- Версии
- 1.0.2-4
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
Первоисточники
- https://github.com/jshttp/on-headers/security/advisories/GHSA-76c9-3jph-rj3q
- https://github.com/jshttp/on-headers/commit/c6e384908c9c6127d18831d16ab0bd96e1231867
- https://cna.openjsf.org/security-advisories.html
- https://github.com/expressjs/morgan/issues/315
- https://github.com/jshttp/on-headers/issues/15
- https://nvd.nist.gov/vuln/detail/CVE-2025-7339