CVE-2026-100697
CVE-2026-100697 · Adminer 6.0.0 Server-Side Request Forgery via ClickHouse driver
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Adminer 6.0.0 through 6.0.1, when the official ClickHouse driver plugin (plugins/drivers/clickhouse.php, rewritten in 6.0.0) is loaded, is vulnerable to pre-authentication server-side request forgery. An unauthenticated attacker can submit auth[driver]=clickhouse with auth[server] set to an arbitrary URL (for example http://127.0.0.1:18089), causing the Adminer server to issue an HTTP POST containing 'SELECT version()' to that host. In rootQuery(), if the target returns a status outside 200-299 (other than 401/403), the raw HTTP response body is assigned to the connection error and rendered on the login page, so the attacker receives the full response body of the internal service. This enables internal network/port reconnaissance and disclosure of sensitive information contained in internal error pages (stack traces, internal hostnames, file paths, configuration identifiers). Fixed in Adminer 6.0.2.
CVSS 5.3 · Средний · EPSS 0,4% · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
adminer
- Версии
- ≥ 0, < 6.0.2: Затронуто (semver)
- 6.0.2: Не затронуто (semver)
Обновитесь до 6.0.2
adminer Debian:12
- Версии
- 4.8.1-1
- 4.8.1-2
- 4.8.1-4
- 5.1.0-1
- 5.2.1+dfsg-1
- 5.3.0+dfsg-1
- 5.4.0+dfsg-1
- 5.4.1+dfsg-1
- 5.4.2+dfsg-1
- 5.4.3+dfsg-1
- 5.4.4+dfsg-1
- 6.0.0-1
- 6.0.1-1
- 6.0.2-1
- 6.1.0-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
adminer Debian:13
- Версии
- 5.2.1+dfsg-1
- 5.3.0+dfsg-1
- 5.4.0+dfsg-1
- 5.4.1+dfsg-1
- 5.4.2+dfsg-1
- 5.4.3+dfsg-1
- 5.4.4+dfsg-1
- 6.0.0-1
- 6.0.1-1
- 6.0.2-1
- 6.1.0-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
adminer Debian:14
- Версии
- 5.2.1+dfsg-1
- 5.3.0+dfsg-1
- 5.4.0+dfsg-1
- 5.4.1+dfsg-1
- 5.4.2+dfsg-1
- 5.4.3+dfsg-1
- 5.4.4+dfsg-1
- 6.0.0-1
- 6.0.1-1
- Затронутые диапазоны версий
- ECOSYSTEM: < 6.0.2-1
Обновитесь до 6.0.2-1
adminer Ubuntu:Pro:16.04:LTS
- Версии
- 4.2.1-1
- 4.2.1-1ubuntu1
- 4.2.1-1ubuntu1+esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
adminer Ubuntu:Pro:18.04:LTS
- Версии
- 4.3.1-2
- 4.5.0-1
- 4.6.1-1
- 4.6.2-1
- 4.6.2-1ubuntu0.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
adminer Ubuntu:Pro:20.04:LTS
- Версии
- 4.7.2-1
- 4.7.4-1
- 4.7.5-1
- 4.7.6-1
- 4.7.6-1ubuntu0.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
adminer Ubuntu:22.04:LTS
- Версии
- 4.7.9-2
- 4.8.1-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
adminer Ubuntu:24.04:LTS
- Версии
- 4.8.1-1
- 4.8.1-1ubuntu1
- 4.8.1-2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
adminer Ubuntu:26.10
- Версии
- 5.4.1+dfsg-1
- 5.4.2+dfsg-1
- 5.4.4+dfsg-1
- 6.0.0-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
adminer Ubuntu:26.04:LTS
- Версии
- 5.2.1+dfsg-1
- 5.3.0+dfsg-1
- 5.4.0+dfsg-1
- 5.4.1+dfsg-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления