CVE-2026-101895
CVE-2026-101895 · Angular SSR: Denial of Service (DoS) via Infinite Loop on Malformed DOCTYPE
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 20.3.31, 21.2.23, and 22.1.6, the @angular/platform-server DOM emulation parser can enter an infinite synchronous loop when Angular server-side rendering processes attacker-controlled HTML containing an incomplete DOCTYPE that ends with whitespace at end of input. In Domino lib/HTMLParser.js, after_doctype_name_state emits doctype and EOF tokens without advancing nextchar or leaving the fixed-lookahead state, so the scanner repeatedly handles the same EOF marker. A remote unauthenticated attacker can use this condition through server-side HTML parsing paths such as innerHTML binding to consume a Node.js SSR worker at full CPU, starve the event loop, and stop concurrent and subsequent requests. This issue is fixed in versions 20.3.31, 21.2.23, and 22.1.6.
CVSS 8.7 · Высокий · EPSS 0,9% · Есть исправление
- Опубликовано
- Обновлено
Затронутые продукты и версии
angular
- Версии
- <= 19.2.25: Затронуто
- >= 20.0.0, < 20.3.31: Затронуто
- >= 21.0.0, < 21.2.23: Затронуто
- >= 22.0.0, < 22.1.6: Затронуто
Нет опубликованного исправления
platform-server
- Версии
- <= 19.2.25: Затронуто
- >= 20.0.0, < 20.3.31: Затронуто
- >= 21.0.0, < 21.2.23: Затронуто
- >= 22.0.0, < 22.1.6: Затронуто
Нет опубликованного исправления
angular.js Debian:12
- Версии
- 1.8.3-1
- 1.8.3-1+deb12u1
- 1.8.3-1+deb12u1~deb11u1
- 1.8.3-2
- 1.8.3-3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
angular.js Debian:13
- Версии
- 1.8.3-3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
@angular/platform-server npm
- Затронутые диапазоны версий
- SEMVER: ≥ 22.0.0, < 22.1.6
Обновитесь до 22.1.6
@angular/platform-server npm
- Затронутые диапазоны версий
- SEMVER: ≥ 21.0.0, < 21.2.23
Обновитесь до 21.2.23
@angular/platform-server npm
- Затронутые диапазоны версий
- SEMVER: ≥ 20.0.0, < 20.3.31
Обновитесь до 20.3.31
@angular/platform-server npm
- Затронутые диапазоны версий
- SEMVER: ≤ 19.2.25
Нет опубликованного исправления
Первоисточники
- https://github.com/angular/angular/security/advisories/GHSA-f67j-2jqw-jpq7
- https://github.com/angular/angular/commit/3db26e2544964d07a520836ad01f02f36ec88e25
- https://github.com/angular/angular/commit/fc2e8fbc0bda2f5c11585e8a0cbd88c074f5e567
- https://github.com/angular/domino/commit/4d97473116d000e3fd4d6f75ec98cbd67576fa6f
- https://github.com/angular/angular/releases/tag/v20.3.31
- https://github.com/angular/angular/releases/tag/v21.2.23
- https://github.com/angular/angular/releases/tag/v22.1.6
- https://nvd.nist.gov/vuln/detail/CVE-2026-101895