p PatchFirst

CVE-2026-102265

CVE-2026-102265 · PyJWT: Uncaught RecursionError in jwt.decode() on deeply nested token header

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

PyJWT is a Python implementation of JSON Web Token standards. From 2.13.0 until 2.14.0, PyJWS._load in jwt/api_jws.py is affected because parser catches ValueError but not RecursionError. This occurs when a deeply nested token header reaches json.loads. As a result, RecursionError escapes the documented PyJWT error hierarchy. Consequently, an unauthenticated malformed token can cause a request-level failure and HTTP 500. This issue is fixed in version 2.14.0.

CVSS 5.3 · Средний · EPSS 0,3% · Есть исправление

Опубликовано
Обновлено

Стек: system · python

Затронутые продукты и версии

  • pyjwt

    Версии
    • >= 2.13.0, < 2.14.0: Затронуто

    Нет опубликованного исправления

  • pyjwt Debian:12

    Версии
    • 2.10.1-1
    • 2.10.1-2
    • 2.10.1-3
    • 2.10.1-4
    • 2.11.0-2
    • 2.12.1-1
    • 2.13.0-1
    • 2.14.0-1
    • 2.15.0-1
    • 2.15.1-1
    • 2.6.0-1
    • 2.6.0-1+deb12u1
    • 2.7.0-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • pyjwt Debian:13

    Версии
    • 2.10.1-2
    • 2.10.1-2+deb13u1
    • 2.10.1-3
    • 2.10.1-4
    • 2.11.0-2
    • 2.12.1-1
    • 2.13.0-1
    • 2.14.0-1
    • 2.15.0-1
    • 2.15.1-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • pyjwt Debian:14

    Версии
    • 2.10.1-2
    • 2.10.1-3
    • 2.10.1-4
    • 2.11.0-2
    • 2.12.1-1
    • 2.13.0-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.14.0-1

    Обновитесь до 2.14.0-1

  • pyjwt PyPI

    Версии
    • 2.13.0
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 2.13.0, < 2.14.0

    Обновитесь до 2.14.0

  • pyjwt Ubuntu:Pro:16.04:LTS

    Версии
    • 1.0.0-0ubuntu1
    • 1.3.0-1
    • 1.3.0-1ubuntu0.1
    • 1.3.0-1ubuntu0.1+esm1
    • 1.3.0-1ubuntu0.1+esm2
    • 1.3.0-1ubuntu0.1+esm3
    • 1.3.0-1ubuntu0.1+esm4
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • pyjwt Ubuntu:Pro:18.04:LTS

    Версии
    • 1.4.2-1.1
    • 1.5.3+ds1-1
    • 1.5.3+ds1-1ubuntu0.1
    • 1.5.3+ds1-1ubuntu0.1+esm1
    • 1.5.3+ds1-1ubuntu0.1+esm2
    • 1.5.3+ds1-1ubuntu0.1+esm3
    • 1.5.3+ds1-1ubuntu0.1+esm4
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • pyjwt Ubuntu:Pro:20.04:LTS

    Версии
    • 1.7.0-2
    • 1.7.1-1
    • 1.7.1-2ubuntu1
    • 1.7.1-2ubuntu2
    • 1.7.1-2ubuntu2.1
    • 1.7.1-2ubuntu2.1+esm1
    • 1.7.1-2ubuntu2.1+esm2
    • 1.7.1-2ubuntu2.1+esm3
    • 1.7.1-2ubuntu2.1+esm4
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • pyjwt Ubuntu:22.04:LTS

    Версии
    • 1.7.1-2ubuntu2
    • 2.1.0-1
    • 2.3.0-1
    • 2.3.0-1ubuntu0.1
    • 2.3.0-1ubuntu0.2
    • 2.3.0-1ubuntu0.3
    • 2.3.0-1ubuntu0.4
    • 2.3.0-1ubuntu0.5
    • 2.3.0-1ubuntu0.6
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • pyjwt Ubuntu:24.04:LTS

    Версии
    • 2.7.0-1
    • 2.7.0-1ubuntu0.1
    • 2.7.0-1ubuntu0.2
    • 2.7.0-1ubuntu0.3
    • 2.7.0-1ubuntu0.4
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • pyjwt Ubuntu:26.10

    Версии
    • 2.10.1-4ubuntu1
    • 2.12.1-1
    • 2.13.0-1
    • 2.13.0-1ubuntu1
    • 2.13.0-1ubuntu1.1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • pyjwt Ubuntu:26.04:LTS

    Версии
    • 2.10.1-2
    • 2.10.1-3
    • 2.10.1-3build1
    • 2.10.1-4
    • 2.10.1-4ubuntu1
    • 2.10.1-4ubuntu1.1
    • 2.10.1-4ubuntu1.2
    • 2.10.1-4ubuntu1.3
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →