p PatchFirst

CVE-2026-102272

CVE-2026-102272 · PyJWT BOM Bypass

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

PyJWT is a Python implementation of JSON Web Token standards. From 2.13.0 until 2.14.0, HMACAlgorithm.prepare_key in jwt/algorithms.py is affected because raw-JWK detector does not normalize accepted Unicode byte-order marks before checking for JSON. This occurs when a public JWK is prefixed with a UTF-8 BOM and used in a mixed-algorithm verification path. As a result, public JWK bypasses asymmetric-key detection and becomes the HMAC secret. Consequently, an attacker who knows the public key can forge authenticated tokens. This issue is fixed in version 2.14.0.

CVSS 7.4 · Высокий · EPSS 0,2% · Есть исправление

Опубликовано
Обновлено

Стек: system · python

Затронутые продукты и версии

  • pyjwt

    Версии
    • >= 2.13.0, < 2.14.0: Затронуто

    Нет опубликованного исправления

  • pyjwt Debian:13

    Версии
    • 2.10.1-2
    • 2.10.1-2+deb13u1
    • 2.10.1-3
    • 2.10.1-4
    • 2.11.0-2
    • 2.12.1-1
    • 2.13.0-1
    • 2.14.0-1
    • 2.15.0-1
    • 2.15.1-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • pyjwt Debian:14

    Версии
    • 2.10.1-2
    • 2.10.1-3
    • 2.10.1-4
    • 2.11.0-2
    • 2.12.1-1
    • 2.13.0-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.14.0-1

    Обновитесь до 2.14.0-1

  • pyjwt PyPI

    Версии
    • 2.13.0
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 2.13.0, < 2.14.0

    Обновитесь до 2.14.0

  • pyjwt Ubuntu:Pro:16.04:LTS

    Версии
    • 1.0.0-0ubuntu1
    • 1.3.0-1
    • 1.3.0-1ubuntu0.1
    • 1.3.0-1ubuntu0.1+esm1
    • 1.3.0-1ubuntu0.1+esm2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.3.0-1ubuntu0.1+esm3

    Обновитесь до 1.3.0-1ubuntu0.1+esm3

  • pyjwt Ubuntu:Pro:18.04:LTS

    Версии
    • 1.4.2-1.1
    • 1.5.3+ds1-1
    • 1.5.3+ds1-1ubuntu0.1
    • 1.5.3+ds1-1ubuntu0.1+esm1
    • 1.5.3+ds1-1ubuntu0.1+esm2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.5.3+ds1-1ubuntu0.1+esm3

    Обновитесь до 1.5.3+ds1-1ubuntu0.1+esm3

  • pyjwt Ubuntu:Pro:20.04:LTS

    Версии
    • 1.7.0-2
    • 1.7.1-1
    • 1.7.1-2ubuntu1
    • 1.7.1-2ubuntu2
    • 1.7.1-2ubuntu2.1
    • 1.7.1-2ubuntu2.1+esm1
    • 1.7.1-2ubuntu2.1+esm2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.7.1-2ubuntu2.1+esm3

    Обновитесь до 1.7.1-2ubuntu2.1+esm3

  • pyjwt Ubuntu:22.04:LTS

    Версии
    • 1.7.1-2ubuntu2
    • 2.1.0-1
    • 2.3.0-1
    • 2.3.0-1ubuntu0.1
    • 2.3.0-1ubuntu0.2
    • 2.3.0-1ubuntu0.3
    • 2.3.0-1ubuntu0.4
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.3.0-1ubuntu0.5

    Обновитесь до 2.3.0-1ubuntu0.5

  • pyjwt Ubuntu:24.04:LTS

    Версии
    • 2.7.0-1
    • 2.7.0-1ubuntu0.1
    • 2.7.0-1ubuntu0.2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.7.0-1ubuntu0.3

    Обновитесь до 2.7.0-1ubuntu0.3

  • pyjwt Ubuntu:26.10

    Версии
    • 2.10.1-4ubuntu1
    • 2.12.1-1
    • 2.13.0-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.13.0-1ubuntu1

    Обновитесь до 2.13.0-1ubuntu1

  • pyjwt Ubuntu:26.04:LTS

    Версии
    • 2.10.1-2
    • 2.10.1-3
    • 2.10.1-3build1
    • 2.10.1-4
    • 2.10.1-4ubuntu1
    • 2.10.1-4ubuntu1.1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.10.1-4ubuntu1.2

    Обновитесь до 2.10.1-4ubuntu1.2

Первоисточники

Проверьте свой сервер →