p PatchFirst

CVE-2026-102275

CVE-2026-102275 · PyJWT accepts inconsistent OKP x/d JWKs, causing public/private key identity confusion

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

PyJWT is a Python implementation of JSON Web Token standards. From 2.1.0 until 2.15.0, PyJWT OKPAlgorithm.from_jwk in jwt/algorithms.py is affected because private-JWK import path does not compare the public key derived from d with x. This occurs when an OKP private JWK supplies non-corresponding x and d components. As a result, identity derived from x can differ from operations performed with d. Consequently, if an integration also accepts private key parameters from a proof header without rejecting them, an attacker may use a stolen sender-constrained token without the legitimate private key. This issue is fixed in version 2.15.0.

CVSS 6.5 · Средний · EPSS 0,2% · Публичный эксплойт · Есть исправление

Опубликовано
Обновлено

Стек: system · python

Затронутые продукты и версии

  • pyjwt

    Версии
    • >= 2.1.0, < 2.15.0: Затронуто

    Нет опубликованного исправления

  • pyjwt Debian:12

    Версии
    • 2.10.1-1
    • 2.10.1-2
    • 2.10.1-3
    • 2.10.1-4
    • 2.11.0-2
    • 2.12.1-1
    • 2.13.0-1
    • 2.14.0-1
    • 2.15.0-1
    • 2.15.1-1
    • 2.6.0-1
    • 2.6.0-1+deb12u1
    • 2.7.0-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • pyjwt Debian:13

    Версии
    • 2.10.1-2
    • 2.10.1-2+deb13u1
    • 2.10.1-3
    • 2.10.1-4
    • 2.11.0-2
    • 2.12.1-1
    • 2.13.0-1
    • 2.14.0-1
    • 2.15.0-1
    • 2.15.1-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • pyjwt Debian:14

    Версии
    • 2.10.1-2
    • 2.10.1-3
    • 2.10.1-4
    • 2.11.0-2
    • 2.12.1-1
    • 2.13.0-1
    • 2.14.0-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.15.0-1

    Обновитесь до 2.15.0-1

  • pyjwt PyPI

    Версии
    • 2.1.0
    • 2.10.0
    • 2.10.1
    • 2.11.0
    • 2.12.0
    • 2.12.1
    • 2.13.0
    • 2.14.0
    • 2.2.0
    • 2.3.0
    • 2.4.0
    • 2.5.0
    • 2.6.0
    • 2.7.0
    • 2.8.0
    • 2.9.0
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 2.1.0, < 2.15.0

    Обновитесь до 2.15.0

  • pyjwt Ubuntu:22.04:LTS

    Версии
    • 1.7.1-2ubuntu2
    • 2.1.0-1
    • 2.3.0-1
    • 2.3.0-1ubuntu0.1
    • 2.3.0-1ubuntu0.2
    • 2.3.0-1ubuntu0.3
    • 2.3.0-1ubuntu0.4
    • 2.3.0-1ubuntu0.5
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.3.0-1ubuntu0.6

    Обновитесь до 2.3.0-1ubuntu0.6

  • pyjwt Ubuntu:24.04:LTS

    Версии
    • 2.7.0-1
    • 2.7.0-1ubuntu0.1
    • 2.7.0-1ubuntu0.2
    • 2.7.0-1ubuntu0.3
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.7.0-1ubuntu0.4

    Обновитесь до 2.7.0-1ubuntu0.4

  • pyjwt Ubuntu:26.10

    Версии
    • 2.10.1-4ubuntu1
    • 2.12.1-1
    • 2.13.0-1
    • 2.13.0-1ubuntu1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.13.0-1ubuntu1.1

    Обновитесь до 2.13.0-1ubuntu1.1

  • pyjwt Ubuntu:26.04:LTS

    Версии
    • 2.10.1-2
    • 2.10.1-3
    • 2.10.1-3build1
    • 2.10.1-4
    • 2.10.1-4ubuntu1
    • 2.10.1-4ubuntu1.1
    • 2.10.1-4ubuntu1.2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.10.1-4ubuntu1.3

    Обновитесь до 2.10.1-4ubuntu1.3

Первоисточники

Проверьте свой сервер →