p PatchFirst

CVE-2026-102276

CVE-2026-102276 · brace-expansion: DoS via uncontrolled recursion in parseCommaParts causing stack exhaustion

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

The brace-expansion library generates arbitrary strings containing a common prefix and suffix. Prior to 1.1.19, 2.1.5, 3.0.7, and 5.0.10, crafted brace patterns can exhaust the native stack in parseCommaParts because parseCommaParts recursively processes the remainder once per brace group and uses push.apply to pass every element of a very large comma-part array as a function argument. Patterns containing many comma-separated brace groups trigger the recursive path, while the large array triggers the argument-array path without deep recursion. These paths cause recursive and argument-array native stack exhaustion before max or maxLength can limit output, potentially terminating the Node.js process in a process-terminating denial of service. This issue is fixed in versions 1.1.19, 2.1.5, 3.0.7, and 5.0.10.

CVSS 7.5 · Высокий · EPSS 0,5% · Есть исправление

Опубликовано
Обновлено

Стек: system · node

Затронутые продукты и версии

  • brace-expansion

    Версии
    • >= 4.0.0, < 5.0.10: Затронуто
    • >= 3.0.0, < 3.0.7: Затронуто
    • >= 2.0.0, < 2.1.5: Затронуто
    • < 1.1.19: Затронуто

    Нет опубликованного исправления

  • node-brace-expansion Debian:12

    Версии
    • 2.0.1+~1.1.0-1
    • 2.0.1+~1.1.0-2
    • 2.0.1-2
    • 2.0.3+~1.1.2-1
    • 2.0.3+~1.1.2-2
    • 2.0.3+~1.1.2-3
    • 2.1.4+~1.1.2-1
    • 2.1.7+~1.1.2-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-brace-expansion Debian:13

    Версии
    • 2.0.1+~1.1.0-2
    • 2.0.3+~1.1.2-1
    • 2.0.3+~1.1.2-2
    • 2.0.3+~1.1.2-3
    • 2.1.4+~1.1.2-1
    • 2.1.7+~1.1.2-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-brace-expansion Debian:14

    Версии
    • 2.0.1+~1.1.0-2
    • 2.0.3+~1.1.2-1
    • 2.0.3+~1.1.2-2
    • 2.0.3+~1.1.2-3
    • 2.1.4+~1.1.2-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.1.7+~1.1.2-1

    Обновитесь до 2.1.7+~1.1.2-1

  • brace-expansion npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 4.0.0, < 5.0.10

    Обновитесь до 5.0.10

  • brace-expansion npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 3.0.0, < 3.0.7

    Обновитесь до 3.0.7

  • brace-expansion npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 2.0.0, < 2.1.5

    Обновитесь до 2.1.5

  • brace-expansion npm

    Затронутые диапазоны версий
    • SEMVER: < 1.1.19

    Обновитесь до 1.1.19

  • node-brace-expansion Ubuntu:18.04:LTS

    Версии
    • 1.1.8-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-brace-expansion Ubuntu:20.04:LTS

    Версии
    • 1.1.8-1
    • 1.1.11-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-brace-expansion Ubuntu:22.04:LTS

    Версии
    • 2.0.0-1
    • 2.0.1-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-brace-expansion Ubuntu:24.04:LTS

    Версии
    • 2.0.1-2
    • 2.0.1+~1.1.0-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-brace-expansion Ubuntu:26.10

    Версии
    • 2.0.1+~1.1.0-2
    • 2.0.3+~1.1.2-2
    • 2.0.3+~1.1.2-3
    • 2.1.4+~1.1.2-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-brace-expansion Ubuntu:26.04:LTS

    Версии
    • 2.0.1+~1.1.0-2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →