p PatchFirst

CVE-2026-102278

CVE-2026-102278 · brace-expansion: DoS via uncontrolled recursion on nested brace groups causing stack exhaustion

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

The brace-expansion library generates arbitrary strings containing a common prefix and suffix. Prior to 1.1.20, 2.1.6, 3.0.8, and 5.0.11, deeply nested brace groups cause expand_() to recurse once per nesting level at comma-member and single-set expansion sites, exhausting the native stack before output limits can apply and potentially terminating the Node.js process. expand_ performs uncontrolled recursion for nested brace alternatives and single-part sets. deeply nested brace groups supplied as an untrusted pattern. expand_ is affected. expand is affected. Comma members is affected. Single set is affected. native stack exhaustion during nested sub-expansion. process-terminating denial of service. This issue is fixed in versions 1.1.20, 2.1.6, 3.0.8, and 5.0.11.

CVSS 7.5 · Высокий · EPSS 0,5% · Есть исправление

Опубликовано
Обновлено

Стек: system · node

Затронутые продукты и версии

  • brace-expansion

    Версии
    • >= 4.0.0, < 5.0.11: Затронуто
    • >= 3.0.0, < 3.0.8: Затронуто
    • >= 2.0.0, < 2.1.6: Затронуто
    • < 1.1.20: Затронуто

    Нет опубликованного исправления

  • node-brace-expansion Debian:12

    Версии
    • 2.0.1+~1.1.0-1
    • 2.0.1+~1.1.0-2
    • 2.0.1-2
    • 2.0.3+~1.1.2-1
    • 2.0.3+~1.1.2-2
    • 2.0.3+~1.1.2-3
    • 2.1.4+~1.1.2-1
    • 2.1.7+~1.1.2-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-brace-expansion Debian:13

    Версии
    • 2.0.1+~1.1.0-2
    • 2.0.3+~1.1.2-1
    • 2.0.3+~1.1.2-2
    • 2.0.3+~1.1.2-3
    • 2.1.4+~1.1.2-1
    • 2.1.7+~1.1.2-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-brace-expansion Debian:14

    Версии
    • 2.0.1+~1.1.0-2
    • 2.0.3+~1.1.2-1
    • 2.0.3+~1.1.2-2
    • 2.0.3+~1.1.2-3
    • 2.1.4+~1.1.2-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.1.7+~1.1.2-1

    Обновитесь до 2.1.7+~1.1.2-1

  • brace-expansion npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 4.0.0, < 5.0.11

    Обновитесь до 5.0.11

  • brace-expansion npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 3.0.0, < 3.0.8

    Обновитесь до 3.0.8

  • brace-expansion npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 2.0.0, < 2.1.6

    Обновитесь до 2.1.6

  • brace-expansion npm

    Затронутые диапазоны версий
    • SEMVER: < 1.1.20

    Обновитесь до 1.1.20

  • node-brace-expansion Ubuntu:18.04:LTS

    Версии
    • 1.1.8-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-brace-expansion Ubuntu:20.04:LTS

    Версии
    • 1.1.8-1
    • 1.1.11-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-brace-expansion Ubuntu:22.04:LTS

    Версии
    • 2.0.0-1
    • 2.0.1-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-brace-expansion Ubuntu:24.04:LTS

    Версии
    • 2.0.1-2
    • 2.0.1+~1.1.0-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-brace-expansion Ubuntu:26.10

    Версии
    • 2.0.1+~1.1.0-2
    • 2.0.3+~1.1.2-2
    • 2.0.3+~1.1.2-3
    • 2.1.4+~1.1.2-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-brace-expansion Ubuntu:26.04:LTS

    Версии
    • 2.0.1+~1.1.0-2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →