p PatchFirst

CVE-2026-10291

CVE-2026-10291 · Enderfga claw-orchestrator Session Grep Endpoint embedded-server.ts validateRegex redos

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

A security vulnerability has been detected in Enderfga claw-orchestrator up to 3.7.0. The impacted element is the function validateRegex of the file claw-orchestrator/src/embedded-server.ts of the component Session Grep Endpoint. The manipulation of the argument body.pattern leads to inefficient regular expression complexity. The attack may be initiated remotely. Upgrading to version 3.7.1 is sufficient to resolve this issue. The identifier of the patch is 3f970a974c65a94555c25af9f2796f11315e4584. It is recommended to upgrade the affected component.

CVSS 5.3 · Средний · EPSS 0,4% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • claw-orchestrator

    Версии
    • 3.0: Затронуто
    • 3.1: Затронуто
    • 3.2: Затронуто
    • 3.3: Затронуто
    • 3.4: Затронуто
    • 3.5: Затронуто
    • 3.6: Затронуто
    • 3.7.0: Затронуто
    • 3.7.1: Не затронуто

    Обновитесь до 3.7.1

  • @enderfga/claw-orchestrator npm

    Затронутые диапазоны версий
    • SEMVER: < 3.7.1

    Обновитесь до 3.7.1

Первоисточники

Проверьте свой сервер →